[Koha] Problem with batch cover image upload

Alvaro Cornejo cornejo.alvaro at gmail.com
Wed Feb 13 03:15:55 NZDT 2019

Hi Mai

Googling around there seems to be an issue with how apache handles headers
after a security patch.

Basically it seems that after the patch space character is not allowed any
more on a header. I have no access to the mentioned file but it will be
worth to check if header "inflating" have a space on it.

Seems this confirms what I'm saying above




Envíe y Reciba Datos y mensajes de Texto (SMS) hacia y desde cualquier
celular y Nextel
en el Perú, México y en mas de 180 paises. Use aplicaciones 2 vias via SMS
y GPRS online
              Visitenos en www.perusms.com

Le mar. 12 févr. 2019 à 07:50, Mai <mai.arakaki at gmail.com> a écrit :

> On  Sat, 2 Feb 2019 13:56:42, Katrin wrote:
> > Hi Mai,
> >
> > just to make sure - are you trying to upload cover images or patron
> images?
> >
> > What kind of files includes your zip file and how are they named?
> >
> > 3.16 is really old by now. I would have suggested to test on a newer
> > version, but you said you already did on 18.05. Was that a local
> > installation one or one of the demos?
> >
> > Katrin
> >
> Dear Katrin,
> Thanks for your answer.
> I'm trying to upload cover images from Tools > Catalog > Upload local cover
> image.
> My zip file contains one image named 0001.jpg (I've also tried with the
> same image on .png format)
> and one .txt file named "DATALINK.txt" where I've listed several
> biblionumbers and the image name separated by a comma; one biblionumber per
> line.Like this:
> 26794, 0001.png
> 26795, 0001.png
> ... and so on.
> (In case it wasn't possible pointing several IDs to the same image, I've
> also tried the same file with two images & two ID's; one for each and get
> the same error)
> I've tried both with and without a space between the comma and the image
> name.
> The 18.05 version I tested this on was a local installation where we're
> planning on migrating our whole database. Presently, we're testing a copy
> of the same database we have at 3.16 and checked that the IDs mentioned
> above do exist.
> The error in my intranet.error.log says the same in both installs.
> [Mon Feb 04 09:50:44.648135 2019] [http:error] [pid 28363] [client]
> AH02429: Response header name '  inflating' contains invalid characters,
> aborting request, referer: /cgi-bin/koha/tools/upload-cover-image.pl
> Thanks a lot for your feedback!
> Regards,
> Mai
> _______________________________________________
> Koha mailing list  http://koha-community.org
> Koha at lists.katipo.co.nz
> https://lists.katipo.co.nz/mailman/listinfo/koha

More information about the Koha mailing list