[Koha] Help debugging Internal Server Error

Doug Dearden dearden at sarsf.org
Tue Feb 23 11:05:02 NZDT 2021

Hey Scott,

What version of Debian are you running?  I updated my /etc/apt/sources.list.d/koha.list file to point to stable and my /etc/apt/sources.list file to point to buster and did the upgrades at the same time.  A foolish move in retrospect, I think I should have upgraded to buster first and made sure everything worked there.  Unless someone else on the list has an idea of why the upgrade isn't working I am going to have to remove 20.11/reinstall 19.05/restore the db and see what happens.  



-----Original Message-----
From: skaman.tx at gmail.com [mailto:skaman.tx at gmail.com] 
Sent: Friday, February 19, 2021 12:32 PM
To: Doug Dearden <dearden at sarsf.org>; 'Alvaro Cornejo' <cornejo.alvaro at gmail.com>
Cc: koha at lists.katipo.co.nz
Subject: RE: [Koha] Help debugging Internal Server Error


I would love to hear the same.  I have been unsuccessfully fighting an upgrade from 19.05 to 20.11.x for two months now.  All errors are missing SQL columns that are not fixed by koha-upgrade-schema.  Just doing an upgrade using the Debian package manager kills Koha altogether.  Hope someone can share this information.


-----Original Message-----
From: Koha <koha-bounces at lists.katipo.co.nz> On Behalf Of Doug Dearden
Sent: Friday, February 19, 2021 1:22 PM
To: Alvaro Cornejo <cornejo.alvaro at gmail.com>
Cc: koha at lists.katipo.co.nz
Subject: Re: [Koha] Help debugging Internal Server Error

Hey Everyone,

Thank you Alvaro and Jonathan for your help, I wanted to report back that I got this fixed and what the problem was in case someone else runs into this.

An error in the plack-opac-error.log appears, and the same warning appears when I did koha-rebuild-zebra with the –v option:

DBD::mysql::st execute failed: Unknown column 'me.exclude_from_local_holds_priority'

I created a new instance, and found that column in the items table on the new instance but not on the old instance.  I added the column with the SQL command:
ALTER TABLE items ADD exclude_from_local_holds_priority tinyint(1) and that fixed it.

I’m not sure why koha-upgrade-schema didn’t fix this.
I have another instance that we stopped using and combined with an existing one.  I tried doing koha-remove, then koha-restore, the koha-upgrade-schema on that instance and it didn’t work.

I am concerned that there may be other database alterations between version 19.05 and that also didn’t make it into the database.  I found a reference to database changes on the wiki but it ends in the 3.x series.

How do I find out what other database schema changes have been implemented between 19.05 and


Doug Dearden
Director / Information Technology
School for Advanced Research (SAR)
PO Box 2188 / Santa Fe / NM / 87504-2188
505.954.7220 / www.sarweb.org<http://www.sarweb.org/>


Receive the SAR monthly E-News: SIGN UP HERE <https://sarweb.org/about/e-news-signup/>


Koha mailing list  http://koha-community.org Koha at lists.katipo.co.nz
Unsubscribe: https://lists.katipo.co.nz/mailman/listinfo/koha

More information about the Koha mailing list