[Koha] Trouble importing authorities, unimarc, koha 3.2.5

Marilen Corciovei marilen.corciovei at nemesisit.ro
Wed Mar 2 09:46:28 NZDT 2011


We are trying to import authorities and biblios from an old system into 
koha but we've run into several problems. There is another recent thread 
related to authorities import but I don't think the problems are related.

Our problem is as following. We tried to import authorities from a marc 
file with the following format:

LDR 00119nx  a22000613
200    _aHERBERT
801  0 _aRO

using the bulkauthimport.pl tool. The tool gives no error and 1 item 
seems imported. However we can see nothing in the interface. I also 
tried to use the stated import from the interface but after some 
research I found a thread saying it is only used for biblios and not 
Upon some digging we noticed the following warn in zebraidx:

22:24:10-01/03 zebraidx(1209) [warn] 
/usr/share/koha325bjarad/etc/zebradb/authorities/etc/dom-config-marc.xml: stylesheet 
authority-zebra-indexdefs.xsl not found in path 

Is there a xsl for unimarc?

I don't know if this is causing the problem. The entries are imported 
and not indexed? Or they are not even imported. Is the marc format wrong 
for unimarc? Also it seems that the unimarc install only creates the 
default authority type. In marc21 there are several created. Can this be 
a cause of problems?

Also, again unrelated to the previous problems when searching for 
authorities from the create biblio page the following error occurs:

Premature end of script headers: auth_finder.pl, referer:

It seems there is no luck for authorities today.

Thank you for any help.
Kind regards,

More information about the Koha mailing list