[Koha] Trouble importing authorities, unimarc, koha 3.2.5

Marilen Corciovei marilen.corciovei at nemesisit.ro
Wed Mar 2 21:29:38 NZDT 2011

To respond to part of my own question, the problem was related to the 
dom/grs1 configuration. dom is the default configuration for authority 
indexing yet it's not supported with unimarc. I changed (in fact 
re-installed) using grs1 config for authority indexing and now I can 
import and see the authorities.

I cannot link them however to biblios since I get this error:

Can't locate object method "new" via package "C4::Heading::UNIMARC" 
(perhaps you forgot to load "C4::Heading::UNIMARC"?) at 
/usr/share/koha325bjarad/lib/C4/Heading.pm line 168.

and there seems to be no Heading::Unimarc package. I only have 

Kind regards,

On 03/01/2011 10:46 PM, Marilen Corciovei wrote:
> Hello,
> We are trying to import authorities and biblios from an old system into
> koha but we've run into several problems. There is another recent thread
> related to authorities import but I don't think the problems are related.
> Our problem is as following. We tried to import authorities from a marc
> file with the following format:
> LDR 00119nx  a22000613
> 009     HERBERT, FRANK
> 200    _aHERBERT
>          _bFRANK
> 801  0 _aRO
>          _bARBJ
> using the bulkauthimport.pl tool. The tool gives no error and 1 item
> seems imported. However we can see nothing in the interface. I also
> tried to use the stated import from the interface but after some
> research I found a thread saying it is only used for biblios and not
> authorities.
> Upon some digging we noticed the following warn in zebraidx:
> 22:24:10-01/03 zebraidx(1209) [warn]
> /usr/share/koha325bjarad/etc/zebradb/authorities/etc/dom-config-marc.xml: stylesheet
> authority-zebra-indexdefs.xsl not found in path
> /usr/share/koha325bjarad/etc/zebradb/authorities/etc:/usr/share/koha325bjarad/etc/zebradb/etc:/usr/share/koha325bjarad/etc/zebradb/marc_defs/unimarc/authorities:/usr/share/koha325bjarad/etc/zebradb/lang_defs/en:/usr/share/koha325bjarad/etc/zebradb/xsl
> Is there a xsl for unimarc?
> I don't know if this is causing the problem. The entries are imported
> and not indexed? Or they are not even imported. Is the marc format wrong
> for unimarc? Also it seems that the unimarc install only creates the
> default authority type. In marc21 there are several created. Can this be
> a cause of problems?
> Also, again unrelated to the previous problems when searching for
> authorities from the create biblio page the following error occurs:
> Premature end of script headers: auth_finder.pl, referer:
> It seems there is no luck for authorities today.
> Thank you for any help.
> Kind regards,
> Len
> www.len.ro
> _______________________________________________
> Koha mailing list  http://koha-community.org
> Koha at lists.katipo.co.nz
> http://lists.katipo.co.nz/mailman/listinfo/koha

More information about the Koha mailing list