[Koha] LOC Z39.50 Connection configuration setup

Galen Charlton gmc at esilibrary.com
Wed Jun 8 01:42:04 NZST 2016


On Mon, Jun 6, 2016 at 10:42 PM, Decka David <ddavid at lib.unitech.ac.pg> wrote:
> I tried yaz-client lx2.loc.gov/LCDB and the result was
> Connecting......error = System (lower-layer) error: connection time out
> What could have been the problem?
> I also tried Z> f @attr 1=4 "special relativity" and shows Not connected yet.

So, one possibility is that there is a firewall blocking the LC Z39.50
server outright, or just your ability to access port 210.  To
distinguish, you could try the following command:

curl http://lx2.loc.gov

If you get a response like the following:

<title>403 Forbidden</title>
<p>You don't have permission to access /
on this server.</p>

... it means that while you are able to access the Z39.50 server on
port 80, access to port 210 is blocked.  If that's the case, your next
step would be to check with your server and network administrators to
see if there is an outgoing block on port 210.


Galen Charlton
Infrastructure and Added Services Manager
Equinox Software, Inc. / Open Your Library
email:  gmc at esilibrary.com
direct: +1 770-709-5581
cell:   +1 404-984-4366
skype:  gmcharlt
web:    http://www.esilibrary.com/
Supporting Koha and Evergreen: http://koha-community.org &

More information about the Koha mailing list