[Koha] Search problems

Layale Bassil lb26 at aub.edu.lb
Fri Feb 14 03:18:11 NZDT 2014

Hello All,

I tried to apply the below fix, but everytime I execute the zebra rebuild function, I get the following error:

"11:14:23-13/02 zebraidx(2157) [warn] default.idx:13: Failed to load ICU chain words-icu.xml"

Any suggestions of what might be wrong? Your help is very much appreciated.

Layale Bassil
Software Engineer – Business Analyst
IT Solutions Delivery Department

American University of Beirut
Office of Information Technology
P.O.Box 11-0236
Riad El-Solh, Beirut 1107 2020, Lebanon
T: +961 (1) 350000 x 3649 | M: +961 (03) 929876
E: lb26 at aub.edu.lb

W . Fb . Fl . T . Y . L . IT

Think Green... Keep it on the Screen… Save a Tree... 

-----Original Message-----
From: koha-bounces at lists.katipo.co.nz [mailto:koha-bounces at lists.katipo.co.nz] On Behalf Of Witoszynskyj Stephan
Sent: Monday, January 06, 2014 4:40 PM
To: koha at lists.katipo.co.nz
Subject: Re: [Koha] Search problems

Hi Katrin,

thank’s a lot! This solved my problem. Apparently, the only thing that was necessary was to switch to yaz-icu and to modify zebradb/etc/default.idx accordingly. I did not create a transliteration table. 

Thank you very much again!


Am 06.01.2014 um 11:10 schrieb Fischer, Katrin <Katrin.Fischer at bsz-bw.de>:

> Hi Stephan,
> in order to search non latin scripts with Koha correctly you need to make sure that you are using ICU with Zebra. Then the search should work nicely. Some notes on how to activate ICU indexing can be found on the wiki - it should also work for Ukrainian:
> http://wiki.koha-community.org/wiki/Correcting_Search_of_Arabic_record
> s
> Hope this helps,
> Katrin
> -----Ursprüngliche Nachricht-----
> Von: koha-bounces at lists.katipo.co.nz im Auftrag von Witoszynskyj 
> Stephan
> Gesendet: Mo 06.01.2014 08:42
> An: koha at lists.katipo.co.nz
> Betreff: [Koha] Search problems
> Hi,
> I am new to Koha. I basically just set-up a fresh Koha 3.14 
> installation on Ubuntu 13.10 using the Debian packages from 
> http://debian.koha-community.org/
> We are a small library with mostly Ukrainian books. We want to catalogue the books in original language (Ukrainian) and therefore in Cyrillic script. After testing Koha after cataloging the first couple of books I experienced the following problem when searching in the Opac:
> Whenever I entered any arbitrary combination of Cyrillic characters (not even real words) in the search field Koha returned all records in the catalogue. Whether there was a match or not.
> If I did the same in Latin script the search only returned matching records only.
> Searching for authorities in the worked if I searched with the "is exactly" option.
> If I had "starts with" or "contains" it worked only for search "in main entry", but not for search "in keyword" or "any heading".
> Does anyone have an idea what could be wrong?
> Regards,
>   Stephan
> _______________________________________________
> Koha mailing list  http://koha-community.org Koha at lists.katipo.co.nz 
> http://lists.katipo.co.nz/mailman/listinfo/koha

Koha mailing list  http://koha-community.org Koha at lists.katipo.co.nz http://lists.katipo.co.nz/mailman/listinfo/koha

More information about the Koha mailing list