[Koha] re index_zebra.pl - out of memory

Mason James mason.loves.sushi at gmail.com
Fri Sep 5 05:33:54 NZST 2008

On 2008/09/5, at 5:10 AM, David Schuster wrote:

> 2 questions
> 1 - OK so when I run the reindex_zebra.pl with -r -w -b (I think  
> those are
> the switches) I'm getting up to almost 34,000 records indexed and then
> getting Out of memory!
> I've loaded - I believe - about 250,000 records.  Surely I can reindex
> without loading it all into memory...??  What am I missing?
> I loaded it in 3 batches and realized that the zebrasrv wasn't  
> running so
> have been trying to rebuild the zebra indexes.
> 2 - what sql or? can I run to actually verify how many Biblio and  
> items I
> have loaded into Koha?

hi David,

whats the error?

ive have problems where rebuild_zebra.pl has barfed over not enough disk

try using the keep option

   -k                      Do not delete export directory.

and watch the disk, my /tmp was blowing out on a 200k index

More information about the Koha mailing list