[Koha] Problem adding biblio records - Biblio.pm at line 1440

CrossroadsDude Livingston_john at lilly.com
Sat Sep 22 01:15:28 NZST 2007

>The problem is "Arguments must be MARC::Field object"
>> I looked at the Biblio.pm file and line 1440 and the line is  
>> ---->$record->delete_field($old_field);<-----
>So, $old_field isn't a MARC::Field object.  That's odd.
>> I've gone through this many times and get consistent errors importing
>> from
>> several z3950 sources and using several different books.
>Which z3950 sources are you using?  We can see a book you tried from
>the log entry, so maybe someone can try on another system and see if
>they get the same error. 

The three z3950 sources we have been using are ....


An example of a record that failed is to import is....

Z3950.LOC.GOV  	The case for Christ :  	Strobel, Lee,  	0310234840(pbk)  

Unfortunately, the volunteers that are putting our church library in place
are worried that we won't be able to get Koha working before it is opened
next weekend. They are opting for a windoz application called resource mate
instead. Koha was my first choice but it looks like time is not on my side
on this one. 

Maybe I can talk them in to migrating later. 

Thanks for taking the time to respond to me, 

John Livingston
Crossroads Community Church
View this message in context: http://www.nabble.com/Problem-adding-biblio-records---Biblio.pm-at-line-1440-tf4464182.html#a12820412
Sent from the Koha - Discuss mailing list archive at Nabble.com.

More information about the Koha mailing list