[Koha] Problems setting up SIP2 in Koha

Bob Ewart bob-ewart at bobsown.com
Wed Feb 22 11:56:23 NZDT 2023

I'm trying to set up  SIP2 so we can purchase e-books from Palace 
Marketplace.  So far they have not been able to connect.

At first we were getting an XML error.  There's a very long <login ... 
in the default SIPconfiguration.xml file which was deleted but not the 
following </login>

I know they were getting in to  our server because I could see the 
errors in the sip logs.

When I deleted the </login> line, I updated a firewall rule in my 
firewall, IPFire, to log all incoming requests from their IP and port 
6001.  Now they aren't getting in.  I just turned off the log request.  
The rule basically says that a TCP message from their IP and port 6001 
should go to our server with that port.

When I first tried the sip_cli_emulator, it complained about not finding 
the C4 libs so I ran:

perl -I /usr/share/koha/lib /usr/local/sbin/sip_cli_emulator.pl -a 
localhost -p 6001 -su <AdminID>-sp <AdminPassword> -l SLA --patron<myID> 
--password <my password>  -m patron_information

and got:

Attempting socket connection to localhost:6001...connected!
Use of uninitialized value $hold_mode in string eq at 
/usr/local/sbin/sip_cli_emulator.pl line 120.
SEND: 9300CN<AdminID>|CO<AdminPassword>|CPSLA|
READ: 940

Login Failed!

I know that both <AdminID>/<AdminPassword> and <myID>/<my password> are 
correct since I logged in to Koha with each of them.

The sip.log is attached.

I do wish that the sip_cli_emulator was in /usr/sbin with all the other 
koha... commands and properly setup so that it could find the C4 libs.

Any suggestions?


More information about the Koha mailing list