[Koha] JSON report only contains partial results

Katrin Fischer katrin.fischer.83 at web.de
Sat Sep 18 21:09:13 NZST 2021

Hi Tasha,

the caching is done server side, so switching the browser would not make
a difference. Try reducing the time the results are cached maybe.

There is also a limit on how many results the JSON reports will show.
This is set by the SvcMaxreportRows system preference. The default is 10
so that can also explain surprising results. I think changing the LIMIT
is just a way to overwrite that preference, so you could do that for
individual reports or up the global limit.

Hope that helps,



On 16.09.21 20:48, Bales (US), Tasha R wrote:
> Any idea why my public report would return almost 2000 results, but the JSON URL for that report (accessed right after I ran the report), would only display a list of 9 results?
> I've tried reindexing to no avail.  I've also tried duplicating and rerunning the report, as well as changing the report category back to "Cataloging" instead of the custom category I'd added.
> In my initial experimentation with reports and their JSON URL's, everything worked perfectly.  Now, besides the above, I'm noticing odd behavior with the "&annotated=1" parameter, in that if I access the annotated report, then subsequently strip off that parameter and navigate again to the report, the output is still annotated.  I attributed this to caching, but I get this behavior even if I try to access the not annotated URL in a different browser.  That doesn't seem possible; I presume there is something about JSON I just don't understand.
> Tasha Bales
> Enterprise Services
> http://isesi.web.boeing.com/
> _______________________________________________
> Koha mailing list  http://koha-community.org
> Koha at lists.katipo.co.nz
> Unsubscribe: https://lists.katipo.co.nz/mailman/listinfo/koha

More information about the Koha mailing list