[Koha] Search problems

Fischer, Katrin Katrin.Fischer at bsz-bw.de
Mon Jan 6 23:10:46 NZDT 2014

Hi Stephan,

in order to search non latin scripts with Koha correctly you need to make sure that you are using ICU with Zebra. Then the search should work nicely. Some notes on how to activate ICU indexing can be found on the wiki - it should also work for Ukrainian:


Hope this helps,


-----Ursprüngliche Nachricht-----
Von: koha-bounces at lists.katipo.co.nz im Auftrag von Witoszynskyj Stephan
Gesendet: Mo 06.01.2014 08:42
An: koha at lists.katipo.co.nz
Betreff: [Koha] Search problems

I am new to Koha. I basically just set-up a fresh Koha 3.14 installation on Ubuntu 13.10 using the Debian packages from http://debian.koha-community.org/

We are a small library with mostly Ukrainian books. We want to catalogue the books in original language (Ukrainian) and therefore in Cyrillic script. After testing Koha after cataloging the first couple of books I experienced the following problem when searching in the Opac:

Whenever I entered any arbitrary combination of Cyrillic characters (not even real words) in the search field Koha returned all records in the catalogue. Whether there was a match or not. 

If I did the same in Latin script the search only returned matching records only. 

Searching for authorities in the worked if I searched with the "is exactly" option.
If I had "starts with" or "contains" it worked only for search "in main entry", but not for search "in keyword" or "any heading".

Does anyone have an idea what could be wrong?


Koha mailing list  http://koha-community.org
Koha at lists.katipo.co.nz

More information about the Koha mailing list