[Koha] Search problems

Manos PETRIDIS egpetridis at gmail.com
Mon Jan 6 22:32:33 NZDT 2014

Same here*: when I search for a (key)word in Greek, using the "Search the
catalog" prompt in the admin interface, I apparently get all the items with
some info or another entered in Greek. Furthermore, if I search for a single
Greek character, "ξ" for example, I get even more results: "N result(s)
found for 'kw,wrdl: ξ'" some of them in Greek, some in Latin alphabets. 

I remembered reading quite some time ago that one had to explicitly set
zebra searches to be utf-aware, and tried to find the relevant threads.
Found the following:
- Cyrillic Character Search w/ Zebra (from May 2010)
- Can we use Unicode to enter records? (from January 2011)
- Tune Koha to enable precise regional language searching (from October

The odd thing is that although mention is made on the older threads, of a
(git) patch to apply when the "out-of-the-box" Unicode functionality didn't
work, the 2013 thread repeats the same instructions, as if the patch hadn't
made it to the current release in the two years that ensued.

If indeed some tuning is needed for koha/zebra to correctly update and query
zebra indexes, I wonder if it would be best set-up in the administrative
interface, in a page where the admin could indicate/check the languages used
in his/her installation's bibliographical entries. Perhaps the
administrative interface could even search through the biblio entries and
propose the languages mentioned in them (in USMARC 041, 008/35-37 or even
008/15-17 for example).

kind regards,

* 	my installation: v3.14 on Debian, freshly installed from packages. 
	QueryFuzzy and QueryWeightFields are enabled, however disabling them
at search-time makes no difference in search results.

-----Original Message-----
From: koha-bounces at lists.katipo.co.nz
[mailto:koha-bounces at lists.katipo.co.nz] On Behalf Of Witoszynskyj Stephan
Sent: Monday, January 06, 2014 9:43 AM
To: koha at lists.katipo.co.nz
Subject: [Koha] Search problems


I am new to Koha. I basically just set-up a fresh Koha 3.14 installation on
Ubuntu 13.10 using the Debian packages from

We are a small library with mostly Ukrainian books. We want to catalogue the
books in original language (Ukrainian) and therefore in Cyrillic script.
After testing Koha after cataloging the first couple of books I experienced
the following problem when searching in the Opac:

Whenever I entered any arbitrary combination of Cyrillic characters (not
even real words) in the search field Koha returned all records in the
catalogue. Whether there was a match or not. 

If I did the same in Latin script the search only returned matching records

Searching for authorities in the worked if I searched with the "is exactly"
If I had "starts with" or "contains" it worked only for search "in main
entry", but not for search "in keyword" or "any heading".

Does anyone have an idea what could be wrong?


Koha mailing list  http://koha-community.org Koha at lists.katipo.co.nz

More information about the Koha mailing list