[Koha] Trouble getting zebra to work

Doug Dearden dearden at sarsf.org
Thu Feb 3 11:23:53 NZDT 2011

Hello all,

I am having some trouble getting searches to work using zebra, and am suspicious that I may have caused my problems as I was going through the setup.  I have set up a test server on Debian Lenny, using git to download koha.  I am planning on doing some work that I hope to contribute back so chose a dev install when I was setting up.  The files are in /home/doug/kohaclone and /home/doug/koha-dev .  I was logged in as root when I ran the install routine, then changed ownership on all the files to the koha user later.  After that, I restored one of my databases from my production server, copied the default koha-conf.xml and edited it to point to the correct database (named 'image').  I did the same with the koha-httpd.conf file, copying it and editing it where needed.  While logged in as "koha", I would get an error when I tried to run rebuild_zebra.pl .  I logged in as root and ran it that way and it didn't throw the error, but searches aren't finding anything.  I then figured out that the new config files I created had root as the owner.  I changed those to have koha as the owner.  The rebuild_zebra.pl script would then run without throwing the error.  I then read a post that indicated being logged in as root when running rebuild_zebra.pl would mess things up, as certain log files and lock files would get created with root as the owner and koha would not be able to access them.

Any idea where I would find these files?  I have several files in /home/doug/koha-dev/var/lock/zebradb/biblios but they are all owned by koha, not root.  There is no koha directory in /var/log .

I don't know what to expect from rebuild_zebra.pl .  I am setting the KOHA_CONF and PERL5LIB variables.  If I run "rebuild_zebra.pl -z -a -b" > /home/doug/zlog.txt the script appears to run (the cursor blinks for a bit, then the command prompt returns), and a 0 byte file named zlog.txt is created.

If I change the system preferences setting to use the no zebra option, then run rebuild_nozebra.pl the indexes are built and searches work.  Returning the system preferences to use zebra breaks things again.

I have a feeling this is an ownership/permissions problem somewhere, either on some files or maybe relating to MySQL.  I'm just not sure where to look or how to troubleshoot.

Thanks for the look.
Doug Dearden
Director, IT
School for Advanced Research

Koha version: OS version ('uname -a'): Linux SAR51Linux 2.6.26-2-686 #1 SMP Thu Nov 25 01:53:57 UTC 2010 i686 GNU/Linux Perl interpreter: /usr/bin/perl Perl version: 5.010000 Perl @INC: /home/doug/kohaclone
MySQL version: mysql Ver 14.12 Distrib 5.0.51a, for debian-linux-gnu (i486) using readline 5.2 Apache version: Server version: Apache/2.2.9 (Debian) Zebra version: Zebra 2.0.45 (C) 1994-2010, Index Data ApS Zebra is free software, covered by the GNU General Public License, and you are welcome to change it and/or distribute copies of it under certain conditions. SHA1 ID: ab5db8f3b991ecc823f92b3c8bfd22ede9b679df Using ICU
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.katipo.co.nz/pipermail/koha/attachments/20110202/92bf887f/attachment.htm 

More information about the Koha mailing list