[Koha] Koha 3.0 Web installer problem

Krishnan Mani krishnanm75 at yahoo.com
Sat Sep 20 16:26:57 NZST 2008

Hi Shriram,

Hope Andy's tip helped solve your problem. 
Usually, the permanent fix for hostname resolution is to edit your /etc/hosts file:

A sample hosts file will look like this (spaces exaggerated here):     localhost.localdomain   localhost  servername
<network-ip-address>     servername.domainname    servername

Then do a "/sbin/hostname -f /etc/hosts" to pick up your hostname. Also, add the ServerName directive into your httpd.conf file and re-start Apache. i am using Apache 2.2.9 on Fedora 9, so things may be slightly different for you.

i encountered similar issues, and i had to work through more things before i had Koha running. So some of the following may help...

The "it works!" page is the default.html or index.html page that ships with Apache and lets you know that at least Apache is running with the basic configuration.

Do you have your own server or are you running on a shared server? 
Did you re-configure Apache, or are you using .htaccess files?
Is cgi-bin enabled and working properly?

If you look at the koha-httpd.conf file that is generated, you will see that there are ScriptAlias directives like:
ScriptAlias /cgi-bin/koha/ "/usr/share/koha/intranet/cgi-bin/"
ScriptAlias /index.html "/usr/share/koha/intranet/cgi-bin/mainpage.pl"

You can try invoking the mainpage.pl directly by using

As you do this, you might want to open a new terminal and do a "tail -f" on the koha-error_log to see any errors as they scroll by. On the standard install, the file is usually at /var/log/koha

On the couple of installs i did, i had to fix problems with missing modules (that were not reported during install) before i had everything up.

Feel free to ask for more help.

Thanks and regards,

krishnan mani

Pune, India

--- On Sat, 20/9/08, Andy Giesler <agiesler at wisc.edu> wrote:
From: Andy Giesler <agiesler at wisc.edu>
Subject: Re: [Koha] Koha 3.0 Web installer problem
To: "'shriram pandey'" <ram.mlib at gmail.com>, koha at lists.katipo.co.nz
Date: Saturday, 20 September, 2008, 1:33 AM

Shri Ram,

Last week I went through a Koha 3 install on Ubuntu 8.04 and tried
"localhost:8080" with the same result -- "It Works!". Then
I realized my

During the installation process I saw a message telling me that, since I
hadn't defined a name for the server, it would use by default. I
glanced at that number too quickly and assumed it was localhost, aka Using and got me to the
right place. 

I hope that'll work for you. In case not, if you haven't checked this
already, please confirm that Apache is listening on port 8080. The file
/etc/apache2/ports.conf should have this line: 

Listen 8080

....Andy Giesler
University of Wisconsin-Madison

-----Original Message-----
From: koha-bounces at lists.katipo.co.nz
[mailto:koha-bounces at lists.katipo.co.nz] On Behalf Of shriram pandey
Sent: Friday, September 19, 2008 6:48 AM
To: koha at lists.katipo.co.nz
Subject: [Koha] Koha 3.0 Web installer problem

Dear List Members,
 I Installed each and every requirements for koha3 on ubuntu 8.04 .
But when i open "localhost:8080", the web installer is not coming.It
shows only the "It Works". I gone through apache settings, but
everything looks fine...

What is the possible solution,

Any suggestion would be highly appreciated.

Shri Ram Pandey
IKM Trainee
NCSI,Indian Institute Of Science,Bangalore
Koha mailing list
Koha at lists.katipo.co.nz

Koha mailing list
Koha at lists.katipo.co.nz

      Get an email ID as yourname at ymail.com or yourname at rocketmail..com. Click here http://in.promos.yahoo.com/address
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.katipo.co.nz/pipermail/koha/attachments/20080920/6e269d80/attachment.htm 

More information about the Koha mailing list