[Koha] New Koha3/Zebra Install; Problems with Zebra and Opac Searches

hurrells at hurrells.ca hurrells at hurrells.ca
Fri Mar 7 05:04:53 NZDT 2008


I am a new Koha admin, 2.99 worked great, now trying out Koha3/Zebra  
on Unbuntu 7.10. I'm having problems with Zebra setup/searching and  
hope somebody has an
idea about this zebra error 109. I can catalogue in koha3, in mysql I can see
items but I cannot search them with zebra.

I installed koha 3.x, had it apt-get or -MCPAN various perl modules. I d/l
both yaz and zebra which I configured and installed. When I run zebra as
root it shows the following in the log after a search (eg: "Dune") which is
a bib and item in my koha system.

Here is what I know/think.

0. ERROR 109 is usually a username/password issue. Is that true?
1. Now starting as root is OK as the /var/run /var/lock files get  
owned by koha.koha which is good.
2. The zebra log below show that by kohauser/password is OK and I'm logging
in I think.
3. The wiki says "configure zebra" however I cannot find any
details about what I have to do.
4. I haven't changed any config files but have kohaadmin'd some of the
branch,fines,rules inside the system.

So if anyone has koha3/Zebra going, had/fixed this error or has an idea
PLEASE contact me with your ideas to try and I'll get right on it. I'll
be considering rolling back to NoZebra towards the end of the weekend.


root at h33:~# zebrasrv -f /etc/koha/koha-conf.xml
10:41:40-06/03 [log] zebra_start 2.0.24 /etc/koha/zebradb/zebra-biblios.cfg
10:41:40-06/03 [log] zebra_start 2.0.24  
10:41:40-06/03 [server] Adding dynamic listener on  
unix:/var/run/koha/zebradb/bibliosocket id=1
10:41:40-06/03 [server] Adding dynamic listener on  
unix:/var/run/koha/zebradb/authoritysocket id=2
10:41:40-06/03 [server] Starting server zebrasrv pid=29758

10:42:11-06/03 zebrasrv(1) [session] Session - OK 1  
unix:/var/run/koha/zebradb/bibliosocket 29767
10:42:11-06/03 zebrasrv(1) [request] Auth idPass kohauser -
10:42:11-06/03 zebrasrv(1) [request] Init OK - ID:81/81  
Name:ZOOM-C/YAZ Version:1.154/3.0.24
10:42:11-06/03 zebrasrv(1) [request] Search biblios ERROR 109 1 1+0  
RPN @attrset Bib-1 @or @or @or @or @or @attr 1=36 @attr 4=1 @attr 6=3  
@attr 9=32 @attr 2=102 Duen @attr 1=4 @attr 4=1 @attr 6=3 @attr 9=28  
@attr 2=102 Duen @attr 1=4 @attr 4=1 @attr 9=26 @attr 2=102 Duen @attr  
4=6 @attr 5=103 @attr 9=16 @attr 2=102 Duen @attr 4=6 @attr 5=1 @attr  
9=14 @attr 2=102 "duen? " @attr 4=6 @attr 9=14 @attr 2=102 Duen
10:42:11-06/03 zebrasrv(1) [session] Connection closed by client

http://www.hurrells.ca: Linux, LAMP, Oracle and Web 2.0 technologies

More information about the Koha mailing list