[Koha] Re: Koha on etch - a pain?

Beda Szukics beda at muri-gries.ch
Tue Nov 6 20:48:33 NZDT 2007

MJ Ray schrieb:
> "Beda Szukics" <beda at muri-gries.ch> wrote:
>> When did you do your install? Some weeks ago or more than two months? 
>> Because I have the feeling the problem has to do with new versions of some 
>> perl modules. 
> Remember, you can find the perl modules which last worked for me at
> http://serene.ttllp.co.uk/~mjr/ (at least until I move them and put a
> redirect in place very soon...).

I was aware of that too. 

Let me describe my current situation: 

Right now I have koha running on two different servers (both running debian 
etch at the moment). On the first one I had installed debian sarge, then the 
basic installation of koha 2.2.8, when 2.2.9 came out I upgraded koha. Most 
things seemed to work fine so I started with some configuration work for 
koha. Some weeks ago I did an upgrade to debian etch. Koha is still working 

My problem with server 1 was that I didnt have a very good internet 
connection from there so I considered using a second server witch has better 
internet connection. On this one I hade installed debian sarge too. This 
time I did the upgrade to debian etch _before_ I installed koha 2.2.9. After 
the problems I with the installation process because of marc-xml (mentioned 
earlier on this list) I installed your packages and was able to install 
koha. But the add-biblio-thing didn't work. Two weeks ago I tried to erase 
everything related to koha and the corresponding perl-modules and did a new 
install of koha 2.2.9 witch went all right. But I had still the same problem 
(I only added some borrower-categories, some itemtypes and library branches, 
but didn't change anything in the MARC-structure). 

Since on my first server koha is still fine I continued to work on that one. 
But I would like to know what the reason for this problem is because it 
seems that I am not the only one experimenting that. I have the impression 
that the upgrade process sarge->etch has something to do with this. 

I hope to be able to try and do a test install of a new etch and koha on the 
weekend and will tell you. 

I still have some problems with z39.50 search. But that's an other question. 

Greetings             Beda

More information about the Koha mailing list