[Koha] problems upgrading to pre5 / z3950

Dwiggins, David DDWIGGIN at nashvill.gannett.com
Wed Nov 19 15:01:30 NZDT 2003

Here are the errors. This comes from me logging into the intranet side,
going to catalog, and then going to catalog maintenance:

[Tue Nov 18 19:17:29 2003] [error] [client] File does not
exist: /usr/local/koha/intranet/htdocs/images/background-mem.gif
[Tue Nov 18 19:17:43 2003] [error] [client] File does not
exist: /usr/local/koha/intranet/htdocs/images/holder.gif
could not find : /usr/local/koha/opac/htdocs/includes/cat-top.inc at
/usr/local/koha/intranet/modules/C4/Output.pm line 368.

When I click on "Circulation," I get:

HTML::Template->new() : Syntax error in <TMPL_*> tag at
n.tmpl : 80. at /usr/lib/perl5/site_perl/5.6.1/HTML/Template.pm line
[Tue Nov 18 19:20:33 2003] [error] [client] Premature end
of script headers: /usr/local/koha/intranet/cgi-bin/circ/circulation.pl

And when I search for a book and then click on the title, I get this:

[Tue Nov 18 19:22:09 2003] [error] [client] File does not
exist: /usr/local/koha/intranet/htdocs/images/background-mem.gif
Field XXX must have at least one subfield at
/usr/lib/perl5/site_perl/5.6.1/MARC/Record.pm line 632
[Tue Nov 18 19:22:34 2003] [error] [client] Premature end
of script headers: /usr/local/koha/intranet/cgi-bin/MARCdetail.pl

I then tried hitting the "create empty biblio" link, and then clicking
on the z3950 search link that appears on this page. At this point, I get
the following repeated each time the page refreshes.

search.pl :  /  /  /  at
/usr/local/koha/intranet/cgi-bin/z3950/search.pl line 52.
NO RANDOM at /usr/local/koha/intranet/cgi-bin/z3950/search.pl line 59.
DBD::mysql::st execute failed: You have an error in your SQL syntax near
'' at line 1 at /usr/local/koha/intranet/modules/C4/Search.pmline 2438.
DBD::mysql::st fetchrow_hashref failed: fetch() without execute() at
/usr/local/koha/intranet/modules/C4/Search.pm line 2439.

I tried deleting or moving everything I could think of relating to koha
and running a fresh install with a new database. I appear to still be
getting the same errors on this new, fresh copy.

I am using simple acquisition, and in the new install I still don't have
a way to do a z3950 search.

I do have a backup of the data, but this system is not yet in production
and the guy who has been doing most of our cataloging is out this week.
So I'm taking the opportunity to leave it down while I mess around with
it. If I have to, I could probably revert back to the old version. But
I'd prefer to get upgraded to 2.0.

Any help is greatly appreciated!

David Dwiggins
Systems Editor/Library Manager
The Tennessean
1100 Broadway
Nashville, TN 37203
ddwiggins at tennessean.com 

-----Original Message-----
From: koha-admin at lists.katipo.co.nz
[mailto:koha-admin at lists.katipo.co.nz]On Behalf Of MJ Ray
Sent: Monday, November 17, 2003 7:46 PM
To: koha at lists.katipo.co.nz
Subject: Re: [Koha] problems upgrading to pre5 / z3950

On 2003-11-17 19:33:12 +0000 "Dwiggins, David" 
<DDWIGGIN at nashvill.gannett.com> wrote:

> I tried running the upgrade script. It seemed to work, and the data 
> appears 
> to be in the database. But after the upgrade, most of the scripts 
> refused to 
> run, complaining about not being able to locate modules.

Yes, I think the upgrade script in pre5 might write some wrong paths 
to the config file. The next release will use the installer routines 
instead. As you noticed, they work more often.

> (Although I just noticed that MARCdetail.pl seems to still 
> doing this, and catmaintain.pl simply returns <html> and nothing 
> else.)

MARCdetail still doing what? Can you give us some lines from 
koha-error.log around the time of the error, please?

catmaintain I know about. There's bug 600 open on bugs.koha.org that 
is the cause of this. You can try the fix there (putting the path to 
includes in intranet-tmpl) as a short-cut, but a real fix should be 
along shortly.

> But now I have another problem. Since the upgrade, there doesn't 
> appear to be 
> a way to use the z3950 search to pull in bibliographic records on new 
> materials.  I am pretty sure that I have the z3950 daemon running 
> correctly, 
> but there is simply no option on the acquisition screen for doing a 
> z3950 
> search.

Are you using simple acqui, or normal?

> Obviously something is fishy about my installation.  Can any offer 
> guidance 
> on what might have gone wrong/how to fix it?

Maybe, maybe not. You backed up just in case we can't help enough, 

MJR/slef     My Opinion Only and possibly not of any group I know.
Please http://remember.to/edit_messages on lists to be sure I read
http://mjr.towers.org.uk/ gopher://g.towers.org.uk/ slef at jabber.at
  Creative copyleft computing services via http://www.ttllp.co.uk/
Koha mailing list
Koha at lists.katipo.co.nz

More information about the Koha mailing list