[Kete] Installing Kete on Debian Lenny

John Billings john at nimhq.net
Wed May 13 23:30:52 NZST 2009

Hi Walter,

I pulled down the master branch, not sure what goes in the 

There is this section here, I think I'm supposed to change:

<!-- [scheme:]host[:port][/databaseName] -->
         <!-- scheme: tcp, ssl, unix, http, sru? -->
<!-- look into changing private server to unix socket and how that 
effects our acts_as_zoom stuff -->
<!-- private is limited to ONLY localhost for security, since passwords 
are passed in clear text, i believe -->
<listen id="privateserver" >private_spec</listen>
<!-- this should catch with the @ wildcard, both localhost and any 
outside ip interface -->
<listen id="publicserver" >public_spec</listen>

I see in the error message when I start zebra:

10:36:40-13/05 [server] Adding dynamic listener on private_spec id=1
10:36:41-13/05 [fatal] Failed to listen on private_spec
10:36:41-13/05 [server] Adding dynamic listener on public_spec id=2
10:36:41-13/05 [fatal] Failed to listen on public_spec
10:36:41-13/05 [server] Adding dynamic listener on tcp:@:9999 id=0
10:36:41-13/05 [server] Starting server zebrasrv pid=30893

It seems like both "public" and "private" fail to start, and some 
default server is getting started.

After looking at those commented lines in the config, and the output 
from the zebra startup I was able to guess the <listen id> lines should 
look like:

<listen id="privateserver" >tcp:localhost:9902/private</listen>
<listen id="publicserver" >tcp:@:9901/public</listen>

When I tried that it looked like it started ok:

10:44:21-13/05 [server] Adding dynamic listener on 
tcp:localhost:9902/private id=1
10:44:21-13/05 [server] Adding dynamic listener on tcp:@:9901/public id=2
10:44:21-13/05 [server] Starting server zebrasrv pid=31451

kete at kete:~/nim/zebradb$ lsof -i | grep zeb
zebrasrv 32050 kete    4u  IPv4 224517       TCP localhost:9902 (LISTEN)
zebrasrv 32050 kete    6u  IPv6 224520       TCP *:9901 (LISTEN)

Now it's starting to make sense to me.  I've never used Zebra before so 
this is all new to me.

I went and edited the table at site/zoom_dbs/list and edited the public 
port number back, I had changed it to 9999 to match where I saw Zebra 
running before.

Then cd ..

kete at kete:~/nim$ rake zebra:start
(in /home/kete/nim)


kete at kete:~/nim$ rake zebra:load_initial_records RAILS_ENV='production'
(in /home/kete/nim)
  Initial record added to public zebra instance (OAI identifier: 
oai:oai:New It Make!::bootstrap:Bootstrap:1).
  Initial record added to private zebra instance (OAI identifier: 
oai:oai:New It Make!::bootstrap:Bootstrap:1).

And now I'm rewarded with some more docs to read on the front page :)

I was able to upload an audio file, and seems to be running fine. 
Thanks for your help.  I'll run through the install again, and set up a 
development site.  I plan to use kete as a website for the community 
radio show I'm working on, seems like it's a good fit.


Walter McGinnis wrote:
> Morning John,
> We haven't run through a Lenny install yet.  Thanks for being a pioneer.
> Notes below.
> On May 12, 2009, at 10:21 PM, John Billings wrote:
>> Hi,
>> I'm working on getting kete running on a Lenny VPS.  Just following the
>> Etch tutorial, I've managed to get it mostly installed, but stuck on
>> configuring the site.  The site I'm working on is here:
>> http://newitmake.org/
>> Before this, I was having trouble with the Zebra integration.  It seems
>> there was discrepancy somewhere about what port it should be on.  It
>> appears to be running on port 9999:
>> kete at kete:~$ lsof -i | grep zebra
>> zebrasrv 1705 kete    4u  IPv6   2031       TCP *:9999 (LISTEN)
> I suspect that some zebra initialization has failed and it does indeed 
> look to me like your kete site can't find the Zebra instance.  Probably 
> the private one.
> What branch of Kete's git repository are you running off of?  An 
> incompatibility with the latest Zebra may be the cause if you are 
> running Kete 1.1.  We are just about release 1.2 from the master 
> branch.  Please use the master branch if you aren't already.  You'll 
> probably want to start over (except required software) if you aren't 
> running off master already.
>> In the administration interface, it had the "public" server on port
>> 9901, I tried changing that here:
>> http://newitmake.org/site/zoom_dbs/list
>> Here is a cut/paste of the table there:
>> ===
>> Zoom Dbs
>> Database name     Description     Host     Port     Zoom user     Oai 
>> Pmh Repository Sets    
>> No Entries
>> public     Where we store our publicly searchable records (about topics,
>> images, videos, etc.).     localhost     9999     kete     -    
>> loading indicator     Edit     Delete     Show
>> private     Where we store records that are only searchable to privileged
>> Kete users (about topics, images, video, etc.).     localhost     
>> 9902     kete     -    
>> loading indicator     Edit     Delete     Show
>> ===
>> I followed the docs I found in zebradb/README to start up Zebra, when I
>> start without daemonizing, I just noticed the private instance is not
>> starting:
>> kete at kete:~/nim/zebradb$ zebrasrv -f conf/kete-zebra-servers.xml
> As mentioned in zebradb/README it is a bit out of date.  We'll edit that 
> today.  First up, kill that running zebra instance.
> After that check that zebradb/conf/kete-zebra-servers.xml's listen 
> elements' values match what you have in your mysql database port wise.  
> Edit till they do.
> then from one directory up (your application root directory):
> rake zebra:start
> then
> rake zebra:load_initial_records
> Then try reloading the site's homepage.
> Let me know how that goes.  Please post log/zebra.log if things are 
> still failing.
> Cheers,
> Walter

More information about the Kete mailing list