[Koha] Fwd: Dead Koha Resuscitation

Bruce A. Metcalf library at augustansociety.org
Mon May 15 04:37:44 NZST 2023


I have a problem with a dead Koha instance than I cannot resolve:

I had Koha 21.05 installed on Debian 9 with packages. Previous updates 
to both had worked fine.

I recently tried to update to 21.11 and Debian 10 (with packages). I did 
both at once because both were at end-of-life and 21.11 needs Deb 10 or 
better anyway. The virtual machine came back up fine, as did other apps 
on the machine (including other Apache servers).

Koha, however, did not come back up. I tried a variety of ways to start 
and restart, without any response (i.e.: not even an error message). The 
logs don't offer any intelligible data (which may be my fault).

I am also unable to locate commands like koha-create, koha-enable, 
koha-dump, koha-list, etc., getting a "command not found" error.

I tried apt remove koha-common / apt install koha-common without a 
change in symptoms.

Any suggestions about what to try next would be most appreciated.

1. Is there something undocumented that is needed for such an upgrade?

3. Can I install a new instance in the same virtual machine and transfer 
the settings and data?

4. Any other suggestions that don't involve firearms?

Thanks for whatever suggestions you may have to share.

/ Bruce /
Bruce A. Metcalf, Librarian
The Augustan Library

More information about the Koha mailing list