[Koha] Koha Fines script not running.

Rupinder Singh jessedhammu at gmail.com
Tue Jun 6 01:33:49 NZST 2023

I configured my Circulation and Fine rules, and also did the settings in
koha administration for fines.
But when I tried to run my cronjob manually, it gave following error.

/bin/sh: 1: misc/cronjobs/fines.pl: not found

I figured out my fines.pl file is located in "/usr/share/koha/bin/cronjob"
directory. I tried running it from there, and the terminal threw the
following error.

Can't locate Koha/Script.pm in @INC (you may need to install the
Koha::Script module) (@INC contains: /usr/share/webmin /etc/perl
/usr/local/share/perl/5.34.0 /usr/lib/x86_64-linux-gnu/perl5/5.34
/usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl-base
/usr/lib/x86_64-linux-gnu/perl/5.34 /usr/share/perl/5.34
/usr/local/lib/site_perl) at /usr/share/koha/bin/cronjobs/fines.pl
line 33.
BEGIN failed--compilation aborted at
/usr/share/koha/bin/cronjobs/fines.pl line 33.

I tried installing "Koha::Scrip" from CPAN modules but couldn't find
anything. However, I was able to install another Cpan package. By the name
"Koha::Contrib::Tamil", but this was of no help too.

Please suggest. How do I configure my Ubutnu 22.04 server to automatically
run these fines.pl script. Am i doing something wrong?

Thank you
Rupinder Singh

More information about the Koha mailing list