[Koha] Fallout from DBMS Auto Increment Bug

Charles Kelley cmkelleymls at gmail.com
Tue Mar 15 15:46:36 NZDT 2022

    It looks like my library was hit by the auto increment bug.

    Yesterday, we implemented the Koha temporary fix on <
https://wiki.koha-community.org/wiki/DBMS_auto_increment_fix>. In addition
to the Koha bug fix, we added the suggestions from the Open School
Solutions <

    To our surprise, it worked. Everything worked, in fact. We even
reindexed the catalog (koha-elasticsearch --rebuild -d -v

    So we began testing the catalog again.

    In the course of our testing, we got an internal server error. As far
as we can tell, the error occurred when we were working on both a
cataloging record and an authority record. Then the cataloger saved the
edits of the cataloging record. The cataloging record included a ‡9 link to
the authority record, but Koha had not quite finished indexing the
authority record.

    Since then, every attempt to reboot the server, restart MariaDB, run
the DBMS auto increment fix -- yes, it's already in the boot-up routines --
reindex the catalog through koha-elasticsearch has failed. When we read the
Server Information tab under About Koha, we read this little gem:

ElasticSearch: Nodes: localhost:9200 | Status: running | Indices:
koha_asdlib_biblios (count: 10000), koha_asdlib_authorities (count: 0)

    We can find only a few records in the catalog and no records in the
authority headings.

    What's worse is that when I query MariaDB directly on the server, it
tells me

MAX (biblionumber) = 19276
MAX (authid) = 14373

    Can someone tell us why MariaDB can get accurate counts, but
ElasticSearch cannot?

    I am also perplexed that koha-elasticsearch cannot resolve host
{library} and then proceeds to reindex the catalog.

    An insight into this would also be helpful. We'll probably back up to
the last version of the catalog before the bugs began affecting it and then
upload the changes anew. (At least, we can still download the bibliographic
and authority records intact whether or not ElasticSearch can index them

    Many thanks.

System information
    Koha v. 20.05
    Debian 9 "Stretch" on VirtualBox 6.1.X



    -- Charles.

    Charles Kelley, MLS
    PSC 704 Box 1029
    APO AP 96338

    Charles Kelley
    Tsukimino 1-Chome 5-2
    Tsukimino Gaadenia #210
    Yamato-shi, Kanagawa-ken
    〒242-0002 JAPAN

    +1-301-741-7122 [US cell]
    +81-80-4356-2178 [JPN cell]

    mnogojazyk at aol.com [h]
    cmkelleymls at gmail.com [p]

    linkedin.com/in/cmkelleymls <http://www.linkedin.com/in/cmkelleymls>
    Meeting Your Information Needs. Virtually.

More information about the Koha mailing list