[Koha] Error 500 in Koha OPAC but NOT Staff Catalog After Running Linux System Update

Charles Kelley cmkelleymls at gmail.com
Tue Jun 22 20:04:41 NZST 2021

Hello, all!

    Yesterday, I updated my library's entire catalog. What we did was to
exchange the CCODE and LOC. It worked fine. It took all day and part of
today, but it worked. Then I ran Linux system updates. It too worked fine
-- in staff mode.

    In the patron mode, it's another story. It shows the search screen but
instead of the bib. record with the holdings, we see this response for
every record search:

Sorry, the requested page is not available
> Error 500
> This message can have the following reason(s):
> An error occurred while processing your request.
> What's next?
> You can use the menu and links at the top of the page
> You can search our catalog using the search form at the top of this page.
> Return to the catalog home page.
> Report issues and broken links
> To report this error, please contact the Koha Administrator. Send email.

    First, what does this mean?

    Second, how do I fix this? If the staff can see the records, ought not
the patrons, also? Since the patrons cannot see the results -- results that
the staff can see, mind you -- why can't the patrons? Did something break
in the last system update? If so, what so?

    Thanks for you help.

    Koha v. 20.05
    Linux Debian v. 9.13 "Stretch"


    気を付けて。 /ki wo tukete/ = Take care.

    -- Charles.

    Charles Kelley, MLS
    PSC 704 Box 1029
    APO AP 96338

    Charles Kelley
    Tsukimino 1-Chome 5-2
    Tsukimino Gaadenia #210
    Yamato-shi, Kanagawa-ken
    〒242-0002 JAPAN

    +1-301-741-7122 [US cell]
    +81-80-4356-2178 [JPN cell]

    mnogojazyk at aol.com [h]
    cmkelleymls at gmail.com [p]

    linkedin.com/in/cmkelleymls <http://www.linkedin.com/in/cmkelleymls>
    Meeting Your Information Needs. Virtually.

More information about the Koha mailing list