[Koha] Software error: Koha Web Installer-MARC21

Pablo Bianchi pablo.bianchi at gmail.com
Sun Oct 8 09:29:00 NZDT 2017

2017-09-20 8:09 GMT-03:00 Dimitris Antonakis <dimantonak at gmail.com>:

> You were right Chris.
> Everything works like a charm using mariadb.

​I had some problems installing Koha on Ubuntu 16.04. One was solved
with wizzyrea
advice <https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13359#c6> of
installing mariadb-server before koha-common. I though that was unimportant.

Other problem was: If you get a timeout, or accidentally clic a second time
on submit button you'll probably get something like
  DBIx::Class::Storage::DBI::_dbh_execute(): Duplicate entry '14-16' for
key 'PRIMARY' at /usr/share/koha/lib/Koha/SearchField.pm line 38
In those cases a I solve it with koha-remove and start again (this work
if plugin='unix_socket' beside this <https://askubuntu.com/a/801950/349837>
The timeout of course could be solved with apache2.conf directive.
The later, maybe web installer could disable submit button
(onsubmit="this.submit_button.disabled=true;") and give some feedback of
the status of the process, particularly when creating tables and filling
them with data (in my case 4 and 6 minutes each).

Also, if you use --use-memcached You'll get
  DBIx::Class::Storage::DBI::catch {...} (): DBI Connection failed: Access
denied for user 'koha_library'@'localhost' (using password: YES)
Was hard to find the solution since koha-shell library was working fine.
The solution: Flush cache: echo flush_all > /dev/tcp/localhost/11211

Best regards,

More information about the Koha mailing list