[Koha] Can't locate Koha/Cache.pm

Arayik Manukyan araik at flib.sci.am
Fri Sep 23 20:11:09 NZST 2016

Hi list.

We have installed koha3.22.10Tarball version on Ubuntu 14.04 version

Now when we tray to install additional language we have such error


root at host-93-94-220-102:/usr/share/koha/misc/translator# sudo perl 
translate install hy-Armn
Can't locate Koha/Cache.pm in @INC (you may need to install the 
Koha::Cache module) (@INC contains: /etc/perl /usr/local/lib/perl/5.18.2 
/usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 
/usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .) at 
/etc/perl/C4/Context.pm line 112.
BEGIN failed--compilation aborted at /etc/perl/C4/Context.pm line 112.
Compilation failed in require at LangInstaller.pm line 22.
BEGIN failed--compilation aborted at LangInstaller.pm line 22.
Compilation failed in require at translate line 25.
BEGIN failed--compilation aborted at translate line 25.

we tried such command   cp   -a   /usr/share/koha/lib/C4/ /etc/perl/

but we had the same error

and we tried via cpan install Koha::Cache and reaceved error


Warning: Cannot install Koha::Cache, don't know what it is.


Now how we can solve this problem?

More information about the Koha mailing list