[Koha] Koha::Contrib::Tamil

tommaso spazzali spazzali at magritte.it
Fri Sep 16 03:58:38 NZST 2016

Thanks Frédéric for the quick answer.

I tried to install from CPAN:

sudo apt-get install build-essential
perl -MCPAN -e shell
install Koha::Contrib::Tamil

the installation procedure raises some error:

Test Summary Report
t/00-compile.t (Wstat: 3072 Tests: 29 Failed: 12)
  Failed tests:  2-12, 19
  Non-zero exit status: 12
Files=1, Tests=29,  7 wallclock secs ( 0.02 usr  0.00 sys +  6.50 cusr
0.68 csys =  7.20 CPU)
Result: FAIL
Failed 1/1 test programs. 12/29 subtests failed.
make: *** [test_dynamic] Errore 12
10 dependencies missing
additionally test harness failed
  /usr/bin/make test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:
  reports FREDERICD/Koha-Contrib-Tamil-0.048.tar.gz
Failed during this command:
 XAOC/ExtUtils-PkgConfig-1.15.tar.gz          : writemakefile NO -- No
'Makefile' created

 XAOC/Glib-1.322.tar.gz                       : writemakefile NO
'/usr/bin/perl Makefile.PL' returned status 512
 FREDERICD/AnyEvent-Processor-0.006.tar.gz    : make_test NO one
dependency not OK (Glib); additionally test harness failed
 FREDERICD/marc-moose-1.0.33.tar.gz           : make_test NO one
dependency not OK (AnyEvent::Processor)
 FREDERICD/Koha-Contrib-Tamil-0.048.tar.gz    : make_test NO 10
dependencies missing
additionally test harness failed

At the end the module koha-auth is installed but raise the same error I
had before:

Uncaught exception from user code:
	Undefined subroutine &C4::Context::KOHAVERSION called at
/usr/local/share/perl/5.18.2/Koha/Contrib/Tamil/RecordReader.pm line 76.

Zeta: I use unimarc and I hope alzo Zeta does,

in my /etc/koha/koha-sites.conf I have:

## Zebra global configuration variables
# ZEBRA_MARC_FORMAT: 'marc21' | 'normarc' | 'unimarc'
# Specifies the MARC records format for indexing
# default: 'marc21'

# ZEBRA_LANGUAGE: 'en' | 'es' | 'fr' | 'nb' | 'ru' | 'uk'
# Primary language for Zebra indexing
# default: 'en'

# BIBLIOS_INDEXING_MODE: 'dom' | 'grs1'
# Indexing mode for bibliographic records
# default: 'dom'

I don't know where else I can check how Zebra is indexing my record.

thanks again

Il 15/09/2016 16:31, Frédéric Demians ha scritto:
>> sudo apt-get install libkoha-contrib-tamil-perl
>> I had some problem with koha-auth. The file RecordReader.pm makes a call
>> to a subroutine called KOHAVERSION in C4::Context that is missing.
> The packaged version is not maintained by the Koha community, and as so is
> obsolete. You have to install it from CPAN.
>> ERROR: ZOOM ZOOM error 239 "Record syntax not supported" (addinfo:
>> "1.2.840.10003.5.10") from diag-set 'Bib-1'
> There is something wrong with your Zebra indexes. Generally, this error means
> that your biblio records are in MARC21 in Koha DB, and defined as Unimarc in
> Zebra, or vice-versa.

Tommaso Spazzali
Magritte S.n.c. di Paolo Ferrarese & C.
Via Meda, 25
20136 - Milano
tel: +39.02-89408830
PGP Key: http://pgpkeys.mit.edu:11371/

I dati personali che ci avete fornito o che ci fornirete saranno oggetto
di trattamento ai sensi del D. Lgs. 196/2003 attraverso strumenti idonei
a garantirne la sicurezza, per le finalita' connesse ad attivita'
commerciali nonche' di adempimento ad obblighi di legge. Il titolare del
trattamento e' la societa' Magritte S.n.c.. Vi ricordiamo che potete
esercitare i diritti di cui all’art. 7 del D. Lgs. 196/2003 consultabili
sul sito del garante della Privacy: http://www.garanteprivacy.it

More information about the Koha mailing list