[Koha] HTTPD::Bench::ApacheBench error

Arayik Manukyan araik at flib.sci.am
Fri Sep 9 23:04:12 NZST 2016





Hi List,

When  we tried  to install latest version on *Ubuntu 12.04 LTS
koha-3.20.14  .

*After  that step

**./koha_perl_deps.pl -m -u    for checking*Ubuntu Packages for Perl

we received such result.


Required          Module is
Module Name                                   Version Version
DBIx::Class::Schema::Loader                   0 *
0.07039                 Yes
HTTPD::Bench::ApacheBench                     0 * 0.73                    No

Total modules reported: 2                      * Module is missing or
requires an upgrade.


*We tried to install  via cpan*

cpan[1]> install HTTPD::Bench::ApacheBench

*and received such error*


Running Mkbootstrap for ApacheBench ()
chmod 644 "ApacheBench.bs"
"/usr/bin/perl" -MExtUtils::Command::MM -e 'cp_nonempty' --
ApacheBench.bs ../blib/arch/auto/HTTPD/Bench/ApacheBench/ApacheBench.bs 644
"/usr/bin/perl" "/usr/share/perl/5.14.2/ExtUtils/xsubpp"  -typemap
'/usr/share/perl/5.14/ExtUtils/typemap'  ApacheBench.xs > ApacheBench.xsc
mv ApacheBench.xsc ApacheBench.c
cc -c   -D_REENTRANT -D_GNU_SOURCE -DDEBIAN -fno-strict-aliasing -pipe
-fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -O2 -g   -DVERSION=\"0.73\" -DXS_VERSION=\"0.73\"
-fPIC "-I/usr/lib/perl/5.14/CORE" ApacheBench.c
/bin/sh: 1: cc: not found
make[1]: *** [ApacheBench.o] Error 127
make[1]: Leaving directory `/root/.cpan/build/ApacheBench-0.73-vdGlU_/src'
make: *** [subdirs] Error 2
    /usr/bin/make -- NOT OK
Running make test
    Can't test without successful make
Running make install
    Make had returned bad status, install seems impossible
Failed during this command:
   ADIRAJ/ApacheBench-0.73.tar.gz               : make NO

*andhad got  second error after command*

cpan[1]> install DBIx::Class::Schema::Loader


    Database was generated on Fri, 09 Sep 2016 04:17:02 GMT
DBIx::Class::Schema::Loader is up to date (0.07046).


help with suggestion  how to solve this problem?



Koha mailing list  http://koha-community.org
Koha at lists.katipo.co.nz

More information about the Koha mailing list