[Koha] [Koha-devel] Koha 3.4.1 upgarde - failed: Access denied for user 'kohaadmin'@'localhost' (using password: YES)

MJ Ray mjr at phonecoop.coop
Fri Jun 3 21:52:53 NZST 2011

ISM KIS asked:
> I have reinstalled koha 3.4.1 and I'm able to access the admin web interface. 
> But when I run the update scripts I still get
> remove_items_from_biblioitems.pl --run
>   DBI connect('dbname=koha;host=localhost;port=3306','kohaadmin',...) failed:
>   Access denied for user 'kohaadmin'@'localhost' (using password: YES) at
>   /opt/kohaclone/koha-tmpl/lib/C4/Context.pm line 692
> I'm on SuSE 11.3
> Anyone else with the same problem?

There are several things to check:

    * Are your environment variables set correctly? Try this as the
      user zebra runs as (koha by default): export
      PERL5LIB=/path/to/your/koha/ (this is the directory above where
      your C4 directory is) and export
      KOHA_CONF=/path/to/your/koha-conf.xml and run the script again.

    * Make sure that you are pointing to the correct koha-conf.xml,
      and that you don't have duplicates.

based on http://koha-community.org/documentation/faq/installingupgrading/

Hope that helps,
MJ Ray (slef), member of www.software.coop, a for-more-than-profit co-op.
http://koha-community.org supporter, web and LMS developer, statistician.
In My Opinion Only: see http://mjr.towers.org.uk/email.html
Available for hire for Koha work http://www.software.coop/products/koha

More information about the Koha mailing list