[Koha] LDAP auth and Active Directory

Nijnatten, Jan van jan.v.nijnatten at philips.com
Wed Sep 16 21:19:32 NZST 2009

Hi Henri-Damien, Joe, all,

Indeed that latest patch seems to get me further ... but Koha can't add the authenticated member ....
I'm sure you guys know what final step I must take to make this work... well hoping at least ....:

[Wed Sep 16 11:08:55 2009] [error] [client] [Wed Sep 16 11:08:55 2009] opac-user.pl: DBD::mysql::st execute failed: Cannot add or update a child row: a foreign key constraint fails (`koha/borrowers`, CONSTRAINT `borrowers_ibfk_2` FOREIGN KEY (`branchcode`) REFERENCES `branches` (`branchcode`)) at /home/koha/source/C4/Members.pm line 770, <DATA> line 253., referer:
[Wed Sep 16 11:08:55 2009] [error] [client] [Wed Sep 16 11:08:55 2009] opac-user.pl: AddMember failed at /home/koha/source/C4/Auth_with_ldap.pm line 145., referer:


Jan van Nijnatten MSc | information architect  |  Philips Research - HTC 34 p076 |  +
From: Henri-Damien LAURENT [henridamien.laurent at gmail.com] On Behalf Of LAURENT Henri-Damien [henridamien.laurent at biblibre.com]
Sent: Tuesday, September 15, 2009 6:59 PM
To: Nijnatten, Jan van
Cc: Joe Atzberger; koha at lists.katipo.co.nz
Subject: Re: [Koha] LDAP auth and Active Directory

Nijnatten, Jan van a écrit :
> Hi Joe,
> Thanks for the suggestion, but I'm still stuck:
> My auth_with_ldap.pm is probably before June 30th (, so I patched it.
> Tried the principal_name tag with the correct domain but then the logging states:
> [Tue Sep 15 17:31:31 2009] [error] [client] [Tue Sep 15 17:31:31 2009] opac-user.pl: Can't call method "exists" on an undefined value at /home/koha/source/C4/Auth_with_ldap.pm line 168, <DATA> line 253., referer:
> If i don't patch auth_with_ldap.pm and don't use principal_name I'm getting:
> [Tue Sep 15 17:43:56 2009] [error] [client] [Tue Sep 15 17:43:56 2009] opac-user.pl: LDAP Auth rejected : invalid password for user 'nlv04101'. LDAP error #16: LDAP_NO_SUCH_ATTRIBUTE, referer:
> I've tried binding and no binding....
> I can search my ldap server; I have the feeling the userPassword entry doesn't exist ... but how do I check?
> Any idea how I can proceed?
> best regards,
> Jan
> ________________________________________
Hi Jan,
I am sending right now a patch accounting for such a problem.
It happens that when auth_by_bind, the search object was never
retrieved, so that things where a little confused.
Henri-Damien LAURENT

The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

More information about the Koha mailing list