[Koha] JSON report only contains partial results

Bales (US), Tasha R tasha.r.bales at boeing.com
Fri Sep 17 06:48:44 NZST 2021

Any idea why my public report would return almost 2000 results, but the JSON URL for that report (accessed right after I ran the report), would only display a list of 9 results?

I've tried reindexing to no avail.  I've also tried duplicating and rerunning the report, as well as changing the report category back to "Cataloging" instead of the custom category I'd added.

In my initial experimentation with reports and their JSON URL's, everything worked perfectly.  Now, besides the above, I'm noticing odd behavior with the "&annotated=1" parameter, in that if I access the annotated report, then subsequently strip off that parameter and navigate again to the report, the output is still annotated.  I attributed this to caching, but I get this behavior even if I try to access the not annotated URL in a different browser.  That doesn't seem possible; I presume there is something about JSON I just don't understand.

Tasha Bales
Enterprise Services

More information about the Koha mailing list