[Koha] Search for "see also" records shows NO RESULTS FOUND

Michael Kuhn mik at adminkuhn.ch
Thu Aug 10 00:42:06 NZST 2017


On 3 August 2017 I wrote:

  ##### ##### #####

After an update from Koha 3.20.4 we work on a new host with Debian 
GNU/Linux 8 and Koha 17.05.1.

Our catalog contains authority records with "see also" records. For 
example the subject "Buchkultur" (MARC 150 $a) has a "see also" record 
"Lesekultur" (MARC 450 $a).

On Koha 3.20 it was possible to search the OPAC for subject "Lesekultur" 
and thus finding the records with subject "Buchkultur".

In Koha 17.05 it will only find the main authority records, but not the 
"see also" records. Thus an OPAC search for "Lesekultur" will find NO 

Why is that so? We have tried to relink all authorities (using script 
"link_bibs_to_authorities.pl"). We have also tried to rebuild the Zebra 
index for the authorities, but to no avail.

Are we missing something?

  ##### ##### #####

Unfortunately I haven't found the solution until now. I only have found 
out the following:

1. No system preferences were changed after the update. This means the 
following system preferences haven't been changed during or since the 

* IncludeSeeFromInSearches: Include
* CatalogModuleRelink: Do not
* KinkerKeepStale: Do not
* Linker module: Default
* LinkerOptions: (empty)
* LinkerRelink: Do

2. In Koha 3.20.4 the search for "see from (non-preferred form) 
headings" showed all the expected results. After the update to Koha 
17.05 these searches do find nothing anymore. (Even though we relinked 
all authorities and also have rebuilt the Zebra index for the authorities).

3. In my own Koha 17.05.1 demo installation with the same system 
preferences set I entered a new authority record with MARC 150 $a 
"Buchkultur" and MARC 450 $a "Lesekultur" (as existing in the productive 
system). Then I added this authority record into the bibliographic 
record MARC 650 $a. Neither in the productive system nor in my demo 
installation the search for "Lesekultur" will show a result.

4. Can anyone positively CONFIRM that in his installation of Koha 
17.05.1 the search for "see from (non-preferred form) headings" does 
show results?

I will appreciate any kind of hint regarding this problem.

Best wishes: Michael
Geschäftsführer · Diplombibliothekar BBS, Informatiker eidg. Fachausweis
Admin Kuhn GmbH · Pappelstrasse 20 · 4123 Allschwil · Schweiz
T 0041 (0)61 261 55 61 · E mik at adminkuhn.ch · W www.adminkuhn.ch

More information about the Koha mailing list