[Koha] Any Helps

Tim Young Tim.Young at LightSys.org
Tue Aug 8 14:10:17 NZST 2017


Hi,

When translating from Spanish to English, some of the error messages are 
a little harder to track down.

In English, the error message is: Unable to correct problems, you have 
held broken packages

And, here is a page that describes the possible problems and solutions

https://askubuntu.com/questions/223237/unable-to-correct-problems-you-have-held-broken-packages



On 8/7/2017 8:43 PM, Luis Moises Rojas wrote:
> Yes, many lines:
> Los siguientes paquetes tienen dependencias incumplidas:
>  koha-common : Depende: libalgorithm-checkdigits-perl pero no es 
> instalable
>                Depende: libanyevent-http-perl pero no es instalable
>                Depende: libarchive-extract-perl pero no es instalable
>                Depende: libauthen-cas-client-perl pero no es instalable
>                Depende: libbiblio-endnotestyle-perl pero no es instalable
>                Depende: libbusiness-isbn-perl pero no es instalable
>                Depende: libbusiness-issn-perl pero no es instalable
>                Depende: libbytes-random-secure-perl pero no es instalable
>                Depende: libcache-fastmmap-perl pero no es instalable
>                Depende: libcache-memcached-fast-perl pero no es instalable
>                Depende: libcache-perl pero no es instalable
>                Depende: libcgi-session-driver-memcached-perl pero no 
> es instalab                        le
>                Depende: libcgi-session-perl pero no es instalable
>                Depende: libcgi-session-serialize-yaml-perl pero no es 
> instalable
>                Depende: libclass-factory-util-perl pero no es instalable
>                Depende: libconvert-basen-perl pero no es instalable
>                Depende: libcrypt-eksblowfish-perl pero no es instalable
>                Depende: libcrypt-gcrypt-perl pero no es instalable
>                Depende: libdata-ical-perl pero no es instalable
>                Depende: libdate-calc-perl pero no es instalable
>                Depende: libdate-manip-perl pero no es instalable
>                Depende: libdatetime-event-ical-perl pero no es instalable
>                Depende: libdatetime-format-ical-perl pero no es instalable
>                Depende: libdatetime-format-mysql-perl pero no es 
> instalable
>                Depende: libdatetime-set-perl pero no es instalable
>                Depende: libdbd-mock-perl pero no es instalable
>                Depende: libdbd-mysql-perl pero no es instalable
>                Depende: libdbd-sqlite2-perl pero no es instalable
>                Depende: libdbix-class-schema-loader-perl pero no es 
> instalable
>                Depende: libdevel-cover-perl pero no es instalable
>                Depende: libemail-date-perl pero no es instalable
>                Depende: libexception-class-perl pero no es instalable
>                Depende: libfont-ttf-perl pero no es instalable
>                Depende: libgd-barcode-perl pero no es instalable
>                Depende: libgd-perl pero no es instalable
>                Depende: libgraphics-magick-perl pero no es instalable
>                Depende: libgravatar-url-perl pero no es instalable
>                Depende: libhtml-scrubber-perl pero no es instalable
>                Depende: libhttp-oai-perl pero no es instalable
>                Depende: liblibrary-callnumber-lc-perl pero no es 
> instalable
>                Depende: liblingua-ispell-perl pero no es instalable
>                Depende: liblingua-stem-perl pero no es instalable
>                Depende: liblingua-stem-snowball-perl pero no es instalable
>                Depende: liblocale-currency-format-perl pero no es 
> instalable
>                Depende: liblocale-maketext-lexicon-perl pero no es 
> instalable
>                Depende: liblocale-po-perl pero no es instalable
>                Depende: liblog-log4perl-perl pero no es instalable
>                Depende: libmail-sendmail-perl pero no es instalable
>                Depende: libmarc-charset-perl pero no es instalable
>                Depende: libmarc-xml-perl pero no es instalable
>                Depende: libmime-lite-perl pero no es instalable
>                Depende: libmodern-perl-perl pero no es instalable
>                Depende: libmodule-bundled-files-perl pero no es instalable
>                Depende: libmodule-pluggable-perl pero no es instalable
>                Depende: libmojolicious-perl (>= 6.0) pero no va a 
> instalarse
>                Depende: libnet-server-perl pero no es instalable
>                Depende: libnet-sftp-foreign-perl pero no es instalable
>                Depende: libnumber-format-perl pero no es instalable
>                Depende: libopenoffice-oodoc-perl pero no es instalable
>                Depende: libpdf-api2-perl pero no es instalable
>                Depende: libpdf-api2-simple-perl pero no es instalable
>                Depende: libpdf-fromhtml-perl pero no va a instalarse
>                Depende: libpdf-reuse-barcode-perl pero no es instalable
>                Depende: libpdf-table-perl pero no es instalable
>                Depende: libplack-middleware-reverseproxy-perl pero no 
> es instala                        ble
>                Depende: libreadonly-perl pero no es instalable
>                Depende: libreadonly-xs-perl pero no es instalable
>                Depende: libschedule-at-perl pero no es instalable
>                Depende: libsereal-decoder-perl pero no es instalable
>                Depende: libsereal-encoder-perl pero no es instalable
>                Depende: libsms-send-perl pero no es instalable
>                Depende: libsoap-lite-perl pero no es instalable
>                Depende: libstring-random-perl pero no es instalable
>                Depende: libswagger2-perl (>= 0.59) pero no va a instalarse
>                Depende: libtemplate-perl pero no es instalable
>                Depende: libtemplate-plugin-json-escape-perl pero no es 
> instalabl                        e
>                Depende: libtemplate-plugin-stash-perl pero no va a 
> instalarse
>                Depende: libtest-deep-perl pero no es instalable
>                Depende: libtest-exception-perl pero no es instalable
>                Depende: libtest-mockmodule-perl pero no es instalable
>                Depende: libtest-mockobject-perl pero no es instalable
>                Depende: libtest-strict-perl pero no es instalable
>                Depende: libtest-warn-perl pero no es instalable
>                Depende: libtest-www-mechanize-perl pero no es instalable
>                Depende: libtest-yaml-valid-perl pero no es instalable
>                Depende: libtext-bidi-perl pero no es instalable
>                Depende: libtext-csv-encoded-perl pero no es instalable
>                Depende: libtext-csv-perl pero no es instalable
>                Depende: libtext-csv-xs-perl pero no es instalable
>                Depende: libtext-pdf-perl pero no es instalable
>                Depende: libtext-unaccent-perl pero no es instalable
>                Depende: libtext-unidecode-perl pero no es instalable
>                Depende: libtime-fake-perl pero no es instalable
>                Depende: libuniversal-can-perl pero no es instalable
>                Depende: libuniversal-require-perl pero no es instalable
>                Depende: libwww-csrf-perl pero no es instalable
>                Depende: libwww-youtube-download-perl pero no es instalable
>                Depende: libxml-dumper-perl pero no es instalable
>                Depende: libxml-libxslt-perl pero no es instalable
>                Depende: libxml-rss-perl pero no es instalable
>                Depende: libxml-sax-writer-perl pero no es instalable
>                Depende: libxml-writer-perl pero no es instalable
>                Depende: xsltproc pero no es instalable
>                Depende: docbook-xsl pero no es instalable
>                Depende: ttf-dejavu pero no es instalable
>                Depende: libxml2-utils pero no es instalable
>                Depende: at pero no es instalable
>                Depende: idzebra-2.0 pero no es instalable
>                Depende: libjs-jquery pero no es instalable
>                Depende: mysql-client pero no es instalable o
>                         virtual-mysql-client
>                Depende: pwgen pero no es instalable
>                Depende: starman pero no es instalable
>                Depende: tinymce pero no es instalable
>                Depende: xmlstarlet pero no es instalable
>                Depende: yaz pero no es instalable
> E: No se pudieron corregir los problemas, usted ha retenido paquetes 
> rotos.
>
>
> On Mon, Aug 7, 2017 at 9:39 PM, Tim Young <Tim.Young at lightsys.org 
> <mailto:Tim.Young at lightsys.org>> wrote:
>
>     Hi there,
>
>     Are there any lines before the "missing dependencies" line? Often
>     it will tell us which dependencies are missing.
>
>     And, had you done an "apt-get update" just before "apt-get install
>     koha-common"?
>
>         - Tim
>
>
>     On 8/7/2017 8:29 PM, Luis Moises Rojas wrote:
>
>         Hello,
>
>         We are trynig to install 16.05, but after: sudo apt-get
>         install koha-common
>         we got the following error:
>         missing dependencies
>
>         This an O/S error, but we have done everything manuals say and
>         nothing
>         happen.
>
>         Any help?
>
>
>
>     _______________________________________________
>     Koha mailing list http://koha-community.org
>     Koha at lists.katipo.co.nz <mailto:Koha at lists.katipo.co.nz>
>     https://lists.katipo.co.nz/mailman/listinfo/koha
>     <https://lists.katipo.co.nz/mailman/listinfo/koha>
>
>
>
>
> -- 
> /*Luis Mois├ęs Rojas P.*/
> /*
> */



More information about the Koha mailing list