[Koha] Buggy OS Upgrade

Arslan Farooq arslanone at gmail.com
Wed Apr 8 15:56:53 NZST 2015

Hi Bruce,

I am on Debian 7.8 (wheezy).

I don't know solution to your problem, but the following may help others to
help you:

I was on Koha 3.18.4 (installed using packages) and tried '*apt-get upgrad*e'
and got the '*The following packages have been kept back*' message for

I tried '*aptitude upgrade*' and it upgraded to Koha 3.18.5 with addition
to '*The following NEW packages will be installed:
libdbix-connector-perl{a}*' message, which did not happen when I did '*apt-get

Now I'm upgraded to 3.18.5 and tried Z39.50 search and added a record with
item. No errors. Works fine.

-- Arslan

On Wed, Apr 8, 2015 at 3:40 AM, Bruce A. Metcalf <
bruce.metcalf at augustansociety.net> wrote:

> Greetings,
> Koha 3.18.5 installed using packages under Debian squeeze.
> This week we upgraded our distro from squeeze to wheezy.
> Now when we try to save a biblio found using Z39.50 search, we get this
> error message:
> Byte order is not compatible at /usr/lib/perl/5.14/Storable.pm line 416 at
> /usr/share/koha/intranet/cgi-bin/cataloguing/additem.pl line 401
> Clearly, we muffed something in the upgrade, but I haven't a clue what.
> Any suggestions, or should I roll back to last week's backup?
> _______________________________________________
> Koha mailing list  http://koha-community.org
> Koha at lists.katipo.co.nz
> http://lists.katipo.co.nz/mailman/listinfo/koha

Assistant Librarian
SZABIST Islamabad
arslan.farooq at szabist-isb.edu.pk
+92 514 863 363-65

More information about the Koha mailing list