[Koha] Upgrading from 3.02.02 (tarball install) to latest

Steven Nickerson snicker1 at maine.rr.com
Fri Jan 31 15:45:20 NZDT 2014

THANK YOU Robin!!!   That worked and did exactly what I needed it to and was
now able to successfully complete my upgrade.   I really appreciate the


-----Original Message-----

Date: Fri, 31 Jan 2014 11:31:12 +1300
From: Robin Sheat <robin at catalyst.net.nz>
To: koha at lists.katipo.co.nz
Subject: Re: [Koha] Upgrading from 3.02.02 (tarball install) to latest
	(package install)
Message-ID: <1391121072.890.1.camel at zarathud>
Content-Type: text/plain; charset="UTF-8"

On do, 2014-01-30 at 17:07 -0500, Steven Nickerson wrote:
> So,
> when I run the 'koha-create' on the new system the DB schema isn't
> named the
> same as the one contained in the MySQL backup that is restored in the
> next
> step and I therefore don't have any data in the "new" version.  Anyone
> have
> any suggestions on how to resolve this properly?

Oh, easy. Where the instructions say:

  $ sudo koha-mysql <instancename> < mybackup.sql

instead do:

  $ sudo koha-mysql <instancename>
  mysql> \. mybackup.sql

This will mean the whole thing doesn't run in a transaction, and the
CREATE DATABASE and USE lines will fail, but this won't abort the whole
import like it does the first way.

Robin Sheat
Catalyst IT Ltd.
? +64 4 803 2204
GPG: 5FA7 4B49 1E4D CAA4 4C38  8505 77F5 B724 F871 3BDF

More information about the Koha mailing list