[Koha] Koha indexing and searching

Phillip Ponchot pponchot at live.com
Wed Aug 21 04:20:05 NZST 2013

Thanks everyone, I've resolved this issue.

From: pponchot at live.com
To: koha at lists.katipo.co.nz
Subject: Koha indexing and searching
Date: Sun, 18 Aug 2013 22:15:04 -0700

I recently checked to see if I had zebrasrv running and then assumed that the indexing was done by the zebra server.  I also see that the lock files etc belong to www.data.  (Linux Server).

I did the following via ssh:
(the directory location below is correct)
1.  Exported
2.  Exported PERL5LIB=/usr/local/koha/lib
3.  Ran the following command: /usr/local/koha/bin/migration_tools/rebuild_zebra.pl -r -b -a
4.  Restarted the Linux Server. 

I then attached to the web site http://catalog.livingstonpubliclibrary.org/ Whenever I search for anything I get the following results: 

No Result found !

    No results match your search for “testing” in Livingston-Park County Public Library Catalog.

I had a couple of issues with the script being able to lock the Koha ..LCK files so I gave these files the same rights as the owner (www.data) and tried again.  Everything seemed to work ok.  

I tried attaching again and searching and still have the error. 

If anyone could please give me some idea of what I am doing wrong or how to fix this issue.  

Is it possible that the website is running the nozebra indexing?  It is my understanding that if Zebra Server is installed (and you are using a website), then Koha is using Zebra Indexing?

phillip ponchot pponchot at live.com



More information about the Koha mailing list