[Koha] problems with Zebra on Ubuntu 12.04

Howell, Lynda Lynda.Howell at myunion.edu
Sat Jun 2 01:31:30 NZST 2012


Thank you!

I don't understand why it wasn't running, but I ran the three commands from the "Setup Zebra Server to Automatically Start on Boot Up" section again

# sudo ln -s /usr/share/koha/bin/koha-zebra-ctl.sh /etc/init.d/koha-zebra-daemon

# sudo update-rc.d koha-zebra-daemon defaults

# sudo /etc/init.d/koha-zebra-daemon start
and the search is working now.

It's lasted through one reboot, so I'll keep my fingers cross it stays this time.

Thanks for your help.


From: Bernardo Gonzalez Kriegel [mailto:bgkriegel at gmail.com]
Sent: Thursday, May 31, 2012 7:12 PM
To: Howell, Lynda
Cc: koha at lists.katipo.co.nz
Subject: Re: [Koha] problems with Zebra on Ubuntu 12.04


is your zebra daemon running?

Apparently you have rebuild the index correclty, but if your zebra daemon is not running, your search will find nothing.

Bernardo Gonzalez Kriegel
bgkriegel at gmail.com<mailto:bgkriegel at gmail.com>

On Thu, May 31, 2012 at 5:50 PM, Howell, Lynda <Lynda.Howell at myunion.edu<mailto:Lynda.Howell at myunion.edu>> wrote:
I have Koha 3.8.1 installed and mostly working on Ubuntu 12.04, and have created/imported a bunch of records to work with.  The problem I'm having is that all searches in the catalog come up with no results.  I can see the records I imported in the reservoir, so I know they're there, but Search the Catalog finds nothing.

There are several related FAQs at http://koha-community.org/documentation/faq/, but I've tried all of the suggestions without any luck.

Here's the command I'm currently using to rebuild the index:

sudo -u koha -H env KOHA_CONF=/etc/koha/koha-conf.xml PERL5LIB=/usr/share/koha/lib /usr/share/koha/bin/migration_tools/rebuild_zebra.pl<http://rebuild_zebra.pl> -b -r -v

The first time I run that, I get a bunch of "[No such file or directory]" error messages about /var/lock/koha/zebradb/biblios -- I've checked, and there really is no /var/lock/koha directory.  If I create those directories (and confirm that the koha user is the owner), I stop seeing error messages.  But I still can't search for records.  And I have to keep recreating this /var/lock/koha directory and subdirectories -- I think they're being deleted when I restart the computer.

I haven't found anywhere that describes what the expected output of rebuild_zebra.pl<http://rebuild_zebra.pl> is.  I've been assuming that no news is good news, but maybe it's not.  For example, I see it  count out dots for all of my records under "exporting biblio", but then it says
       REINDEXING zebra

Without another list of dots (although it pauses between the two lines of ===s for several seconds as if it's doing something).  Is that what it's supposed to do?

I installed Koha following the instructions at http://wiki.koha-community.org/wiki/Koha_on_Ubuntu.  They were written for Koha 3.06 and Ubuntu 11.10, but everything seemed to work as written with only one exception.  In Step 1 under Install Koha, the second command "make" -- gave me
       /usr/bin/perl "-Iblib/arch" "-Iblib/lib" fix-perl-path.PL blib
       Permission denied at fix-perl-path.PL line 88.
       make: *** [blib] Error 13
I changed it to "sudo make", and it worked.  And again with the next command -- "make test" didn't work but "sudo make test" did.  I wouldn't expect that to cause problems like this.

What am I doing wrong?

Thanks for your help.

Lynda Howell.
Koha mailing list  http://koha-community.org
Koha at lists.katipo.co.nz<mailto:Koha at lists.katipo.co.nz>

More information about the Koha mailing list