[Koha] Availability: No items available

umer habib umerhabib76 at yahoo.com
Fri Aug 24 22:11:15 NZST 2012


Sorry there was some problem with my mailbox so i didnt recieve your email last day. I have tried running this utility using "--run" it updates all the records and then i ran "rebuild_zebra.pl -b -r" as was suggested in "remove_items_from_biblioitems.pl" script but my issue is not resolved. It is still giving "availability: no items available"


From: Robin Sheat <robin at catalyst.net.nz>
To: umer habib <umerhabib76 at yahoo.com> 
Cc: "koha at lists.katipo.co.nz" <koha at lists.katipo.co.nz> 
Sent: Friday, 24 August 2012 2:00 PM
Subject: Re: [Koha] Availability: No items available
What happened when you tried what I said when you asked this yesterday?

Specifically here:

Op 24-08-12 10:50, umer habib schreef:
> Hi,
> I have a very strange problem. I have two installations of koha one is 3.2 and other is 3.8, I imported mrc files for records in both the installations seperately and (mrc files have items information as well). For zebra indexing i use the fllowing command on both the installations
> perl /path/to/rebuild_zebra.pl -b -r -v
> Now, in koha 3.2 it works great. all the records and items are added into the serch and every thing is perfect. But in 3.8, items are not added into the search and when i search for a book, then items against the record says availability: no items available, however there are items present in that record. what could be the issue?

In between 3.2 and 3.4, the way items worked changed.

After loading your data in to the database, run the
misc/maintenance/remove_items_from_biblioitems.pl script to fix them up.

This will hopefully help.

Robin Sheat
Catalyst IT Ltd.
✆ +64 4 803 2204
GPG: 5957 6D23 8B16 EFAB FEF8  7175 14D3 6485 A99C EB6D

More information about the Koha mailing list