[Koha] Trouble getting zebra to work

Marilen Corciovei marilen.corciovei at nemesisit.ro
Sat Feb 5 00:34:54 NZDT 2011

Just for info, after having trouble with this myself on several 
occasions, here is the list of files which need to be writable by the 
koha user (supposing single folder install):

$KOHA_HOME/etc/zebradb (read only required)


On 02/03/2011 10:56 PM, Doug Dearden wrote:
> Hi Chris,
> Thanks for your help.  It was permissions related.  My 
> misunderstanding also about having the zebrasrv running from the 
> command line, which wasn’t fired off correctly due to a permissions issue.
> What is the best way to avoid this in the future?  Create the koha 
> user ahead of time, then do the install as that user?  Will that work?
> Best,
> Doug
> *From:*Chris Nighswonger [mailto:cnighswonger at foundations.edu]
> *Sent:* Wednesday, February 02, 2011 4:43 PM
> *To:* Doug Dearden
> *Cc:* Koha
> *Subject:* Re: [Koha] Trouble getting zebra to work
> Hi Doug,
> 2011/2/2 Doug Dearden <dearden at sarsf.org <mailto:dearden at sarsf.org>>
> Hello all,
> I am having some trouble getting searches to work using zebra, and am 
> suspicious that I may have caused my problems as I was going through 
> the setup.  I have set up a test server on Debian Lenny, using git to 
> download koha.  I am planning on doing some work that I hope to 
> contribute back so chose a dev install when I was setting up.  The 
> files are in /home/doug/kohaclone and /home/doug/koha-dev .  I was 
> logged in as root when I ran the install routine, then changed 
> ownership on all the files to the koha user later.  After that, I 
> restored one of my databases from my production server, copied the 
> default koha-conf.xml and edited it to point to the correct database 
> (named ‘image’).  I did the same with the koha-httpd.conf file, 
> copying it and editing it where needed.  While logged in as “koha”, I 
> would get an error when I tried to run rebuild_zebra.pl 
> <http://rebuild_zebra.pl> .  I logged in as root and ran it that way 
> and it didn’t throw the error, but searches aren’t finding anything.  
> I then figured out that the new config files I created had root as the 
> owner.  I changed those to have koha as the owner.  The 
> rebuild_zebra.pl <http://rebuild_zebra.pl> script would then run 
> without throwing the error.  I then read a post that indicated being 
> logged in as root when running rebuild_zebra.pl 
> <http://rebuild_zebra.pl> would mess things up, as certain log files 
> and lock files would get created with root as the owner and koha would 
> not be able to access them.
> Any idea where I would find these files?  I have several files in 
> /home/doug/koha-dev/var/lock/zebradb/biblios but they are all owned by 
> koha, not root.  There is no koha directory in /var/log .
> Check also files under /home/doug/koha-dev/etc/zebradb.
> Koha logs are in /home/doug/koha-dev/var/log
>     I don’t know what to expect from rebuild_zebra.pl
>     <http://rebuild_zebra.pl> .  I am setting the KOHA_CONF and
>     PERL5LIB variables.  If I run “rebuild_zebra.pl
>     <http://rebuild_zebra.pl> –z –a –b” > /home/doug/zlog.txt the
>     script appears to run (the cursor blinks for a bit, then the
>     command prompt returns), and a 0 byte file named zlog.txt is created.
> try './rebuild_zebra.pl <http://rebuild_zebra.pl> -a -b -r -v' for 
> verbose output and to completely rebuild the indexes.
>     If I change the system preferences setting to use the no zebra
>     option, then run rebuild_nozebra.pl <http://rebuild_nozebra.pl>
>     the indexes are built and searches work.  Returning the system
>     preferences to use zebra breaks things again.
> nozebra is basically deprecated and unsupported at this point in Koha 
> history. Avoid it like the plague.
>     I have a feeling this is an ownership/permissions problem
>     somewhere, either on some files or maybe relating to MySQL.  I’m
>     just not sure where to look or how to troubleshoot.
> Probably permissions. Something here may be useful too: 
> http://koha-community.org/documentation/faq/searching/#18
> Kind Regards,
> Chris
> _______________________________________________
> Koha mailing list  http://koha-community.org
> Koha at lists.katipo.co.nz
> http://lists.katipo.co.nz/mailman/listinfo/koha

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.katipo.co.nz/pipermail/koha/attachments/20110204/bbe69f5b/attachment-0001.htm 

More information about the Koha mailing list