[Koha] Koh authorities & searching

Linda Culberson lculber at mdah.state.ms.us
Wed Apr 20 02:25:32 NZST 2011

We had downloaded our authority files from our current system and used 
./bulkauthimport.pl -file authorityfile.mrc to load them and then 
rebuild zebra with the -a switch.

I'm checking now about the 008 field.  The ones I spot checked did have 
the a in the position 14 & 15, but, as I said, some did link, and those 
could have been the ones.  I'll keep checking.

Thanks for the help.

On 4/19/2011 8:43 AM, Elaine Bradtke wrote:
> We are using authorities, ours linked.  But the technical details are
> a bit hazy.
> Our authority records were created in house - extracted from our main
> database into a separate database that was then converted into MARC
> authority records.  It took a couple attempts because we had a few
> settings that were not correct, but it worked.
> I've seen two approaches:
> Use the following command in shell (For default koha installation directory)
> usr/share/koha/bin/migration_tools$ ./bulkauthimport.pl -file authorityfile.mrc
> After that rebuild zebra with -a switch
> or
> bulkmarcimport.pl -a -authorityfile.xml -m MARCXML
> (Either way, rebuilding zebra with -a switch is important).
> Here's a message from the technical half of our team:
> As Elaine pointed out in her earlier letter, we basically solved the
> our initial authority linking problem by fixing the 008 field
> (Position 14 and 15 must be set to 'a' for the linking
> to work.), but
> this only fixed the "PERSO_NAME" authorities.  Our TOPIC_TERM
> authority records were still not getting linked.  These Names and Term
> authorities are locally maintained since the "regular" thesaurus's one
> might use like Library of Congress do not have the level of detail and
> specificity that this specialist resarch library requires
> (http://www.efdss.org/front/library-archive/about-the-vaughan-williams-memorial-library/37).
> We have this working now, but there were two issues.   First and
> easiest to fix was that we were placing our TOPIC_TERMs in a 653
> record, rather than a 650.  C4::Heading::MARC21 has a table of
> bib_heading_fields, and 653 is not included.  We researched 650 a bit
> and realized that we probably should just use that, but we wanted to
> be correct and not claim these terms were sourced from someplace like
> LC.  So we created a 650, with a second indicator of '7' (other), and
> subfields 'a' set to the term, and '2' set to our library identifier
> 'UkLoVW'.  When we tried to use link_bibs_to_authorities.pl, it failed
> to link these terms.  Some debugging and generous printfs indicated
> that the problem was in the query against the Zebra index.
> Specifically, the problem was with the line:
>           $limiters .= " AND Subject-heading-thesaurus=$self->{'thesaurus'}";
> Commenting out this line (and thus the constraint that the entry in
> Zebra have a thesaurus of 'UkLoVW') solved the problem.
> Query before change:
>   authorities:SimpleSearch(Match-heading,ext="Aberdeenshire" AND
> at='TOPIC_TERM' AND Heading-use-subject-added-entry=a AND
> Subject-heading-thesaurus=UkLoVW)
> Query after change:
>   authorities:SimpleSearch(Match-heading,ext="Aberdeenshire" AND
> at='TOPIC_TERM' AND Heading-use-subject-added-entry=a)
> I don't know if this was the right thing to do and I suspect if I put
> in a patch to delete that line, it would be rejected.
> Here is an example (from marcdump) of one of our terms.  This MARC was
> generated by a python program I wrote to convert from a bespoke term
> database to MARC so there could definitely be issues with this which I
> would happily fix.  Comments are welcome.
> LDR 00234nz## 2200109n######
> 001     AT-000001
> 003     UkLoVW
> 005     20101106220637.0
> 008     101106|ge|dz||aaan##########||||c###|d
> 035    _aAT-000001
> 040    _aUkLoVW
>        _beng
>        _cUkLoVW
> 150    _aAberdeen
> The real problem is why did Zebra not have our entries label with the
> correct thesaurus entry?  Thiis code in C4::Heading/_query_limiters()
> looks a bit suspect anyways with lots of "FIXME" comments by someone.
> So where is the real problem - does Zebra need fixing?  Our authority
> MARC records?  Koha C4::Heading?  What should we do to resolve this
> permanently?
> Regards,
>     -Doug-
> On Mon, Apr 18, 2011 at 8:10 PM, Linda Culberson
> <lculber at mdah.state.ms.us>  wrote:
>> All,
>> This brings me to a question we've been grappling with here, and that is
>> how/whether to get Koha to work with authorities.  We had used
>> link_bibs_to_authorities.pl but found that, as Jared indicated, very few
>> of our imported records actually did link.  Most didn't.
>> I would like to get a sense of whether libraries are using authorities
>> in Koha, and if so, how?  Were the headings locally established or were
>> they purchased?  In other words, how were they generated?   Please
>> contact me off list if that is more convenient, and/or this is something
>> that no one else might be interested in.
>> Thanks!
>> Linda
>> On 4/18/2011 9:55 AM, Jared Camins-Esakov wrote:
>>> Linda,
>>> au: searches use text matching. an: searches use the authority links.
>>> Imported records never (or almost never) have authority links, so when
>>> you upgrade to 3.4 (due out very soon!) you'll probably want to change
>>> the UseAuthoritiesForTracings to "Don't use," so that the tracings don't
>>> generate links using the (incomplete) an: searches.
>>> Regards,
>>> Jared
>>> On Mon, Apr 18, 2011 at 10:49 AM, Linda Culberson
>>> <lculber at mdah.state.ms.us<mailto:lculber at mdah.state.ms.us>>  wrote:
>>>      All,
>>>      I may be misunderstanding how some of the links in Koha work, or we
>>>      could have a problem with our authorities. Either way, I'd appreciate
>>>      any help and/or insight.
>>>      In Koha, if I do just a general keyword search for "Mississippi Dept of
>>>      Transportation" I get 180 results. If I do an author search I get 150
>>>      results
>>>      If I click on one of the links for which that department is the author,
>>>      and then click on its "by" link it goes to an:7261 and I only get 16
>>>      results. Some of those are the department as subject and others as it
>>>      as author.
>>>      I thought au was the author index, and am assuming it is using the
>>>      authorities?
>>>      Any help would be appreciated.
>>>      Thanks in advance.
>>>      --
>>>      Linda Culberson        lculber at mdah.state.ms.us
>>>      <mailto:lculber at mdah.state.ms.us>
>>>      Archives and Records Services Division
>>>      Ms. Dept. of Archives&  History
>>>      P. O. Box 571
>>>      Jackson, MS 39205-0571
>>>      Telephone: 601/576-6873
>>>      Facsimile: 601/576-6824
>>>> --
>>> Jared Camins-Esakov
>>> Freelance bibliographer, C&  P Bibliography Services, LLC
>>> (phone) +1 (917) 727-3445
>>> (e-mail) jcamins at cpbibliography.com<mailto:jcamins at cpbibliography.com>
>>> (web) http://www.cpbibliography.com/
>> --
>> Linda Culberson                 lculber at mdah.state.ms.us
>> Archives and Records Services Division
>> Ms. Dept. of Archives&  History
>> P. O. Box 571
>> Jackson, MS 39205-0571
>> Telephone:  601/576-6873
>> Facsimile:  601/576-6824
>> _______________________________________________
>> Koha mailing list  http://koha-community.org
>> Koha at lists.katipo.co.nz
>> http://lists.katipo.co.nz/mailman/listinfo/koha

Linda Culberson			lculber at mdah.state.ms.us
Archives and Records Services Division
Ms. Dept. of Archives & History
P. O. Box 571
Jackson, MS 39205-0571
Telephone:  601/576-6873
Facsimile:  601/576-6824

More information about the Koha mailing list