[Koha] no item type and Not Renewable

Marty ontariowolf64 at yahoo.com
Sat Mar 13 03:40:52 NZDT 2010

Still searching, but it seems that the marcxml field in biblioitems is incomplete for the items that do not work, I seem to be missing some subfields, and some subfields that are filled in wrong match the wrong items showing up on the edit item page.
Now I have to find a way to change these

--- On Thu, 3/11/10, Marty <ontariowolf64 at yahoo.com> wrote:

From: Marty <ontariowolf64 at yahoo.com>
Subject: Re: [Koha] no item type and Not Renewable
To: "Owen Leonard" <oleonard at myacpl.org>
Cc: "koha koha" <koha at lists.katipo.co.nz>
Received: Thursday, March 11, 2010, 4:54 PM

I liked your idea, it made sense. I found the only difference in items was cn_source and itype. However, changing these does not solve my problem. Alas. I tried and failed.

But it hasn't all been in vain. Playing around I noticed that the Edit Items radio button (from the Details page) returns this url; 
(I cannot really do anything on this page, except deleting the item)

and the route through the barcode from the Details page brings me to Item Details to edit Items (the one under the barcode, not the radio button) returns this url;
But on this page I have an "Edit item #4796"
I still cannot do anything with the existing item,
 except delete it,  but all the needed fields are present below it, and clicking on save changes will work.

Also still wondering; where does it get the itype information?

I am not yet pulling my hair out, but it's not far away...

So close, but yet so far, sigh

Thanks for all your help,


--- On Thu, 3/11/10, Owen Leonard <oleonard at myacpl.org> wrote:

From: Owen Leonard <oleonard at myacpl.org>
Subject: Re: [Koha] no item type and Not Renewable
To: "Marty" <ontariowolf64 at yahoo.com>
Cc: "koha koha" <koha at lists.katipo.co.nz>
Received: Thursday, March 11, 2010, 8:22 AM

> Now I have 2 lines with items showing at the top of the page. I can delete the first one (which is
 wrong anyway), and
> after doing a rebuild_zebra -b -w it all shows up fine and working.

So the item which *doesn't* work is one which you imported into Koha?
If the duplicate created by Koha works (can be placed on hold) then it
sounds like there must be some difference between the two which you
could discern. I would query the items table for the data on the
original and the duplicate and see how they differ. You might be able
to do a bulk update on the existing items without doing your
duplication process.

  -- Owen

Web Developer
Athens County Public Libraries

      Be smarter than spam. See how smart SpamGuard is at giving junk email the boot with the All-new Yahoo! Mail 
-----Inline Attachment Follows-----

Koha mailing list
Koha at lists.katipo.co.nz

Looking for the perfect gift? Give the gift of Flickr! 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.katipo.co.nz/pipermail/koha/attachments/20100312/2ad89d52/attachment.htm 

More information about the Koha mailing list