[Koha] bulkmarcimport.pl for MICROLIF.001 from Follett

ISM KIS Ism at kis.in
Mon Mar 30 23:34:18 NZDT 2009

I did convert the Follett file with the script given by Doug (Thanks)
So I got the file ML.mrc (see attachment)
But when I run the bulkmarcimport.pl this is the error I get:
linux-teck:/usr/share/koha/bin/migration_tools # perl bulkmarcimport.pl -v 2 -c MARC21 -file /usr/share/koha/bin/migrationtools/ML.mrc -d
deleting biblios
Characteristic MARC flavour: UNIMARC
.substr outside of string at /usr/share/koha/lib/C4/Charset.pm line 241, <GEN10> line 1.
linux-teck:/usr/share/koha/bin/migration_tools #
If I run the command with -s then the test is all ok and it says 16 records are processed.
I'm probably just confused with UNIMARC and MARC21
Here is my question:
1) How do I know whether my file ML.mrc is UNIMARC or MARC21  ?
2) How do I know whether my Koha is running UNIMARC or MARC21 ? (Stupid question, yes, I did setup the system, but how can I check now?)
Thanks for any help.
Rudy Wuthrich
Kodaikanal International School

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.katipo.co.nz/pipermail/koha/attachments/20090330/44c02b4e/attachment-0001.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ML.mrc
Type: application/mrc
Size: 13777 bytes
Desc: not available
Url : http://lists.katipo.co.nz/pipermail/koha/attachments/20090330/44c02b4e/attachment-0001.bin 

More information about the Koha mailing list