[Koha] re index_zebra.pl - out of memory

Galen Charlton galen.charlton at liblime.com
Fri Sep 5 05:31:21 NZST 2008


On Thu, Sep 4, 2008 at 12:10 PM, David Schuster <dschust1 at tx.rr.com> wrote:
> 1 - OK so when I run the reindex_zebra.pl with -r -w -b (I think those are
> the switches) I'm getting up to almost 34,000 records indexed and then
> getting Out of memory!
> I've loaded - I believe - about 250,000 records.  Surely I can reindex
> without loading it all into memory...??  What am I missing?

You probably need to bump up the maximum size that Zebra allows for
its register and shadow.  These are set in zebra-biblios.cfg,  Look
for entries like this:

register: /path/to/biblios/register:4G
shadow: /path/to/biblios/shadow:4G

The "4G" indicates that the register's maximum size is 4 gigabytes.

> 2 - what sql or? can I run to actually verify how many Biblio and items I
> have loaded into Koha?

select count(*) from biblio;
select count(*) from items;


Galen Charlton
VP, Research & Development, LibLime
galen.charlton at liblime.com
p: 1-888-564-2457 x709
skype: gmcharlt

More information about the Koha mailing list