[Koha] bulkmarcimport.pl problems

Joshua M. Ferraro jmf at liblime.com
Fri May 18 05:46:27 NZST 2007

----- "Bo Schafers" <bo at weavebrain.com.au> wrote:
> M. Ferraro wrote:
> > Try this:
> >
> > # chmod 755 bulkmarcimport.pl
> >
> >   
> Thanks for the superfast response. Yeah I tried that, but then  I get
> the following when executing the script:
> Can't locate C4/Context.pm in @INC (@INC contains: /etc/perl 
> /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 
> /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 
> /usr/local/lib/site_perl .) at bulkmarcimport.pl line 26.
> BEGIN failed--compilation aborted at bulkmarcimport.pl line 26.
> So it's looking for: C4::Context    ?????
> Tried to cpan C4::Context but it fails:
> Going to write /root/.cpan/Metadata
> Warning: Cannot install C4::Context, don't know what it is.
> So its some missing dependency, or that much-dreaded incompatibility
> of Koha with MySql 5. The trouble is in Debian only an empty transitional
> package is available of 4.1.
OK, this has to do with your perl path. You will have to tell perl
where to find C4 like this:

# perl -I /path/to/modules bulkmarcimport.pl

BTW: AFAIK, Koha is fully compatible with 5.0 as of 2.2.9. If you
run into a problem with 5.0, please let us know; but I doubt there
will be any since LibLime has been running our 2.2 installations on
5.0 since Debian Etch was promoted to stable.


Joshua Ferraro                       SUPPORT FOR OPEN-SOURCE SOFTWARE
President, Technology       migration, training, maintenance, support
LibLime                                Featuring Koha Open-Source ILS
jmf at liblime.com |Full Demos at http://liblime.com/koha |1(888)KohaILS

More information about the Koha mailing list