[Koha] bulkmarcimport.pl problems

Bo Schafers bo at weavebrain.com.au
Fri May 18 04:34:38 NZST 2007

M. Ferraro wrote:
> Try this:
> # chmod 755 bulkmarcimport.pl
Thanks for the superfast response. Yeah I tried that, but then  I get 
the following when executing the script:

Can't locate C4/Context.pm in @INC (@INC contains: /etc/perl 
/usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 
/usr/local/lib/site_perl .) at bulkmarcimport.pl line 26.
BEGIN failed--compilation aborted at bulkmarcimport.pl line 26.

So it's looking for: C4::Context    ?????

Tried to cpan C4::Context but it fails:
Going to write /root/.cpan/Metadata
Warning: Cannot install C4::Context, don't know what it is.

So its some missing dependency, or that much-dreaded incompatibility of 
Koha with MySql 5. The trouble is in Debian only an empty transitional 
package is available of 4.1.

Any more ideas, MUCHLY welcome :-)


More information about the Koha mailing list