[Koha] Date problem (still broken) - even on fresh install

Greg Vickers daehenoc at optusnet.com.au
Tue May 15 23:30:41 NZST 2007

Hi all,

Henri-Damien LAURENT wrote:
> Greg Vickers a écrit :
>> Hi all,
>> Greg Vickers wrote:
>>> Hi all,
>>> After the upgrade from 2.2.5 to 2.2.9, we are having the same or 
>>> similar problems to this thread:
>>> http://lists.katipo.co.nz/public/koha/2007-April/011491.html
>>> Anne wrote:
>>> I've been having a real problem with the members page of the system 
>>> tonight. Every time I added a new member to the library it was 
>>> okay... but then when I went to "issue books" it came up in red 
>>> saying "Borrower will leave soon" and refused to let me issue them 
>>> anything. I am thoroughly confused! This happened with (two users). 
>>> Do you know what was happening?
>>> John wrote:
>>> I attempted to manually add an expiry date to the record for xxxxxxx 
>>> but it still doesn't have an entry date.
>>> Now according to that thread, Date::Calc and/or Date::Manip should be 
>>> installed, Date::Calc was installed but Date::Manip was not 
>>> installed, I have installed Date::Manip and asked the librarians to 
>>> test it. Does anyone have any other tips I could try?
>> After installing Date::Manip, the problem is not resolved. I would 
>> gratefully accept any suggestions or assistance.
>> Thanks,
>> Greg
> We tested it on our boxes both in npl and in default templates.
> And it worked.
> It may come out from 2 things :
> - your system preference date is not correctly set (metric us or iso)
> - you enter date in a special way.
> a)send me your log file (koha-error_log in /usr/local/koha/log 
> usually... Please, only the part of what you think has to cope with this 
> error)
> b) tell me which template/which date system you use.
> c) please send me a data set you type in
> i shall tell you what this error comes from.

We did a clean install of Koha on a fresh Debian install and the same 
problem occurs! Has anyone else had this problem or are we the only site 
to have it?

When a new borrower is created, the Joined Date is a ',' (comma) 
character so obviously this gives an undefined result when calculating 
the Expiry Date for that borrower. This looks like it may be a problem 
with how Koha 2.2.9 retrieves the current date from the system Koha is 
running on - does anyone have any comment on the likelihood that this is 
the cause of the problem?


More information about the Koha mailing list