cRe: [Koha] Errors on Koha install on 1&1 server

John Clarke john.clarke at
Fri Jan 26 04:19:32 NZDT 2007

Thanks MJ,

I made a directory $HOME/library/myperl and tried to run the o conf
makpl_arg command like this:

O koha.conf makepl_arg "LIB=~/library/mperl/lib

Which opened up the text editor and did nothing until I pressed "q".
I then just added the three param lines above to the koha.conf (guessing
this was right?) and tried to run the first failed install again:

Perl -MCPAN -e 'install "Mail::Sendmail"'

It ran normally until it was time to send an e-mail. That failed and said
"Permission denied at /usr/shar/perl/5.6.1/ExtUtils/"

Am I supposed to run the from a particular directory? Do I have
to set the installation PREFIX anywhere else?

Any suggestions welcome.


-----Original Message-----
From: MJ Ray [mailto:mjr at] 
Sent: 25 January 2007 14:31
To: uk at; koha at
Subject: cRe: [Koha] Errors on Koha install on 1&1 server

"John Clarke" <uk at> wrote:
> I'm getting numerous permissions and Perl version errors/failures when
> attempting to install Koha on my 1&1 Business Pro account. I've pasted
> of the error messages below. Perhaps the permissions problems occur
> I don't have root access? [...]

Yes.  You absolutely cannot install to /usr/local on that system. You
need to set the installation PREFIX to something under your home
directory (but probably not under your web root directory).  Probably
  mkdir $HOME/myperl
  export SITEPREFIX=$HOME/myperl
would fix most of them, but the official answer for the CPAN shell is
on "man CPAN" under "FAQ" question 5 in my copy:

       5)  I am not root, how can I install a module in a personal

           You will most probably like something like this:

             o conf makepl_arg "LIB=~/myperl/lib \
                               INSTALLMAN1DIR=~/myperl/man/man1 \
             install Sybase::Sybperl

Hope that helps,
MJ Ray - see/vidu
Somerset, England. Work/Laborejo:
IRC/Jabber/SIP: on request/peteble.

More information about the Koha mailing list