[Koha] Another installation question.

Roger Horne roger at hrothgar.co.uk
Thu Aug 9 22:32:00 NZST 2007

The old saying is "do not look a gift-horse in the teeth" and it plainly applies in relation to PD software. So I put forward the next bit with some diffidence.
I installed Koha some years ago but for various reasons  (including the need to add all the books manually, there being no electronic catalogue of any sort) stopped using it. The computer then died and I could not be bothered to search out the relevant backups but decided to reinstall it on a new machine.
So I downloaded koha-s.9.9.tar.gz and unpacked it and started looking at the files. I was somewhat startled to find that most of the text files were totally out of date:
The most recent entry in the changelog is 2004-11-17
INSTALL claims that it is for release 2.0.1 (28 August 2004)
News lists the changes made since v 1.1.1 (and not much later)
README is for v Nov 2004
TODO sets out the changes to be made in the future, culminating with v.1.5.0

INSTALL suggests that:
The perl modules required are:
  DBI, Date::Manip, DBD::mysql, HTML::Template, Digest::MD5,
  MARC::Record, Mail::Sendmail, Event
Optionally, we can also use:
However install.pm suggests a rather larger number of modules and substitutes ZOOM for Net::Z3950 (as does http://search.cpan.org/src/MIRK/Net-Z3950-ZOOM-1.19/README )
It was presumably intended that the docs directory would contain docs about installation and running Koha. but it is empty. Surely there should at least be a link to kohadocs.org (especially since the docs on that site make it plain that Koha must be configured manually before being run) ? 

This next bit is more in the way of a bug report/question and concerns installation.
I should say first that I am aware that Koha does not claim to be compatible with MySQL 5 although the latest version says that it does work partially. (It is unlikely that any distribution other than Debian now includes MySQL 4.) I tried installing - I have not got as fae as trying to run it - on a computer using Suse 10.2 and MySQL 5. 
I ran installer.pl and it produced the usual list of missing modules. There were, however, at least two modules which were not followed by the CPAN software and caused a listed module to fail to install. (I am afraid the bit of paper I wrote the names on has disappeared ...)
But more importantly the installer does not refer to yaz without which ZOOM will not install. I use Suse but the machine in question did not have yaz installed. So I added it using Yast (and a remote repository). But, as someone else has reported, the version installed was too old. So I had to install from the indexdata.dk site. (The simplest way I found was go to "source" for yaz, download, unpack, cd  in a shell to the directory, su, then ./configure, make, make install. This installed yaz v3: whether that will work with Koha is not clear from the documents.)
Once everything was installed I re-ran installer.pm . It requires to be run as root (since it requires access to /etc). So I su'ed to root and continued. 
Several times. Because if you accidentally give the wrong answer to a question as the result of a typo there is no way of correcting it (even before pressing enter). So you have to stop the installer and start again. (I seem to remember mentioning this several years ago and being told that it would be corrected.)
Eventually everything worked until I got to the Database stage. 
Under Database Name I entered Chamslib (instead of Koha). Under DATABASE HOST I accepted the default of localhost. The next entry is Database User. I tried first using my name (lowercase, no spaces). I then gave a pw at Database Password. (And later I entered the correct MySQL root password.) 
The installer crashed. It reported (approx wording) that it could not use roger @ localhost with password YES. 
It had, however, created the database which I had called Chamslib. I had to log onto MySQL as root and delete it before I could try again.
So I tried again, this time accepting the default database user of kohaadmin. The result was the same: crash, and similar error message. So I deleted the Chamslib db again and tried again. This time I used as Database user root and as database pw the MySQL root password which, unsurprisingly, worked.
Since the installer was able to create the db Chamslib, presumably it was correctly using  each time MySQL -u root and the correct passord to do so. But presumably it was not granting the relevant permissions to the koha database user and so not uploading the relevant tables. (As you can see, my knowledge of MySQL is pretty slim.)
When I used root as the the Database User and the MySQL pw as the Database Password I still got some error messages (including uninitialized values). In particular under creating database I got:
DBD::mysql::st execute failed: Invalid default value for 'aqbudgetid' at scripts/updater/updatedatabase line 1717.
DBD::mysql::st execute failed: Invalid default value for 'id' at scripts/updater/updatedatabase line 1717.                                                                  
I have tried installation twice, once on each of two more or less identical computers, each running Suse 10.2, with the same results. I am now about to try on a different machine running Debian Sarge. 
Roger Horne
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.katipo.co.nz/pipermail/koha/attachments/20070809/3dac2d83/attachment.htm

More information about the Koha mailing list